Error: "vDisk is not available. Please check your network PXE boot configuration and restart Imaging Wizard" or "Red X" on Provisioning Server

Error: "vDisk is not available. Please check your network PXE boot configuration and restart Imaging Wizard" or "Red X" on Provisioning Server

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Article ID: CTX133272

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Updated On:

Description

After installing the Target Device Software and rebooting the following symptoms can be seen:

  • A Red X is displayed on top of the vDisk Status Applet in the Tray Bar
  • After running the Imaging Wizard and rebooting the following message is shown: "vDisk is not available. Please check your network PXE boot configuration and restart Imaging Wizard."User-added image

Resolution

There are various troubleshooting steps that can help solve this issue.
 

  • After running the Imaging Wizard it will require a restart. At that point ensure that the vDisk is in Private Image mode.

  • Check boot order settings. If you are using ISO to boot, make sure the VM is set to boot from the DVD Drive

  • ​If using multiple NICs, ensure that the streaming NIC is selected during Target Device Software setup. Go to Advanced NIC Adapter settings to check Provider Order:

    1. From the Network and Sharing Center, click Change Adapter Settings and in the next screen press Alt key. From the menu that appears, select Advanced Settings, as displayed in the following screen shot.
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    2. Ensure that the Streaming NIC is the first listed in the Connection Order.
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  • If using antivirus, ensure to remove the antivirus before installing Provisioning Server Target Device software and creating a vDisk

  • If Symantec Network Threat Protection is installed, remove it from the Image before running the Imaging Wizard
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  • Check for additional Network Filter drivers in the Network Card's Properties, such as the Microsoft Network Monitor Driver and disable them
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  • Ensure there are no filter drivers sitting with higher altitude above the Citrix drivers. If there are, uninstall the software to which they belong.
    Open a command prompt with elevated permission and type fltmc: (Note: luafv and FileInfo are normal Microsoft Windows drivers and do not interfere with PVS)
    User-added image
     


Problem Cause

The vDisk might not be available for the following reasons:

  • Wrong vDisk configuration when Imaging the Master Image

  • Boot order is wrong

  • Wrong NIC order is selected.

  • Antivirus software not configured correctly

  • Symantec Network Threat Protection is installed

  • Additional Network drivers in the stack

  • Additional Filter Drivers with a higher altitude than PVS drivers

Issue/Introduction

This article provides troubleshooting steps to fix the error that appears after a reboot when attempting to use the Imaging Wizard and when experiencing a Red-X in the vDisk Status Tray App.

Additional Information

CTX124185 - Provisioning Services Antivirus Best Practices

CTX117374 - Best Practices for Configuring Provisioning Server on a Network