New Microsoft Excel 2010 Worksheets are Not Shown in Taskbar Even After Enabling the Excel Hook

New Microsoft Excel 2010 Worksheets are Not Shown in Taskbar Even After Enabling the Excel Hook

book

Article ID: CTX133198

calendar_today

Updated On:

Description

When you open a new Microsoft Excel 2010 worksheet, the new sheet is not shown on the taskbar, only the main Microsoft Excel icon is shown on the taskbar. Microsoft Excel 2010 is published on XenApp 6.5 with Windows 2008 R2 server.

Background

The issue did not resolve even after applying the Excel hook described in CTX130371 - Issues Fixed in Citrix XenApp 6.5 for Windows Server 2008 R2.

Resolution

To resolve this issue, ensure that active accessibility hook is not disabled in seamless flags. To reset default seamless settings, use the value 0 (zero) for the following registry key:

HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control/Citrix/wfshell/TWI
Value Name: SeamlessFlags
Value Type: REG_DWORD
Values: 0

Problem Cause

The Excel hook is not injected into any process because the seamless engine component (Sehook20.dll) responsible for the fix fails to load into the user session. Sehook20 fails to load because active accessibility hook is disabled in the Seamless Flags settings. Seamless flags are often used when troubleshooting problematic display issues.

Issue/Introduction

New Microsoft Excel 2010 worksheets are not shown in Taskbar even after enabling the Excel Hook

Additional Information

The previous implementation of Excel hook, which is used to create separate taskbar icons for each Microsoft Excel workbook, does not work for Excel 2010. This fix enables Excel hook for Excel 2010 if the following registry key is set:

On 32-bit Windows
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ExcelHook
Name: Enabled
Type: REG_DWORD
Data: 1

On 64-bit Windows
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\ExcelHook
Name: Enabled
Type: REG_DWORD
Data: 1

Refer to the following Knowledge Center articles for more information:

CTX130371 - Issues Fixed in Citrix XenApp 6.5 for Windows Server 2008 R2

CTX101644 - Seamless Configuration Settings

CTX127043 - Case Study: Troubleshooting Seamless Flag - Custom Application