CitrixHostService Event ID Log Error 1005 - Encryption operation failed

CitrixHostService Event ID Log Error 1005 - Encryption operation failed

book

Article ID: CTX133157

calendar_today

Updated On:

Description

Application Event Log Error 1005

Source Name CitrixHostService

Message

Encryption operation failed with : Citrix.Cds.Security.SecretEncryptionInvalidKeyException: DecryptSecret: Do not have the key for this message

at Citrix.Cds.Security.CAPISecretEncryption.DecryptSecret(Byte ciphertextMessage)

at Citrix.Cds.Security.SecretEncryptionManager.DecryptSecret(Byte ciphertextSecret

Resolution

Update the Hypervisor account and password in the Desktop Studio under Configuration > Hosts by following the given instructions:

  1. Select the connection name and right-click Change details to re-enter the account information (username and password).

    User-added image

  2. Click OK to save the changes.


Problem Cause

This issue might occur if there is a problem with the Hypervisor account being used in XenDesktop, for example the Hypervisor password has been changed.

Issue/Introduction

CitrixHostService Event ID Log Error 1005 - Encryption operation failed