Provisioning Services Console Error is Displayed During KMS Activation

Provisioning Services Console Error is Displayed During KMS Activation

book

Article ID: CTX132995

calendar_today

Updated On:

Description

When changing a virtual disk (vDisk) in private mode to KMS activation and then changing the mode to standard image mode or changing the activation procedure to KMS for a vDisk in standard image mode, the following error message appears, which can be seen in the console.log (when in debug level) or in the console popup:

Failed to map vDisk, no Driver

Resolution

To resolve this issue:

Use a domain user account, which can be added as a local administrator to the Provisioning Server and then run the Provisioning Server Configuration wizard to reconfigure the access of the user on the Database. 

Or

Assign user the right for managing the Network Service account to perform volume maintenance tasks by completing the following procedure:

  1. Open local security policy using gpedit.msc.

  2. Browse to Windows Settings > Security Settings > Local Policies > User Rights Assignment > Perform volume maintenance tasks.

User-added image

  1. Double-click on Perform volume maintenance tasks and add NETWORK SERVICE.
Note: For this resolution, there can be security concerns since network service account is used in other services other than SOAP Service.

Problem Cause

The error occurs only when the SOAPServer.exe or Citrix SOAP Service is running with NT AUTHORITY\Network Service account. The console passes a request to prepare the vDisk for KMS, which requires the SOAP service to update the vDisk file system and registry entries. This update requires the vDisk to be mounted. The Network Service account does not have SE_MANAGE_VOLUME_NAME privilege which causes an “access is denied” error when it tries to mount the vDisk.

Issue/Introduction

This article provides resolution to the console error that appears when Standard Mode Disk is prepared for KMS Activation.

Additional Information

Microsoft - Privilege Constants

CTX129105 – How to Use Multiple Activation Key (MAK) Activation with Automatic Updates

CTX128276 – Configuring KMS Licensing for Windows and Office 2010 and 2013