Colors in Graphics-Specific or Intensive Applications are not Displayed Correctly

Colors in Graphics-Specific or Intensive Applications are not Displayed Correctly

book

Article ID: CTX132709

calendar_today

Updated On:

Description

Adobe Photoshop, or any graphics-specific or intensive application is not representing color correctly in a XenDesktop session.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Remove the Off-Screen surfacing from the applications which are not representing color correctly in the XenDesktop session.

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

On the VDA that hosts the application, add the following registry key and value:

Key: HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA\Thinwire

Value: DisableOssForProcesses

Type: REG_SZ

Data: photoshop.exe

 

This is a sample registry file content:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA\Thinwire]

"DisableOssForProcesses"="photoshop.exe"


Problem Cause

Graphics are compressed and cached when transferred to the client.

Issue/Introduction

This article describes how to force an application to represent colors correctly in a desktop session.

Additional Information

Multiple applications can be listed as data in the registry. Separate multiple process names with semicolons.

The following is a sample registry file with multiple applications:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA\Thinwire]

"DisableOssForProcesses"="photoshop.exe;indesign.exe;illustrator.exe"