Error: "An Error Occurred While Making The Requested Connection"

Error: "An Error Occurred While Making The Requested Connection"

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Article ID: CTX132461

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Updated On:

Description

When starting XenDesktop from the Web Interface screen, the following error message might be displayed:

“An error occurred while making the requested connection”

 User-added image

Upon examining the broker logs, the following error message is displayed:

“The Citrix Broker Service failed to validate a user's credentials on an XML service.
Verify the trust relationships between your domains.
Error details:
User:  ''
Error: 'AccessDenied'
Message: 'ID only credentials received but TrustRequestsSentToTheXmlServicePort=false'”

Web Interface logs the following error message:

“The Citrix servers do not trust the server. This message was reported from the XML Service at address http://localhost/scripts/wpnbr.dll [com.citrix.xml.NFuseProtocol.RequestAddress].”
 

Resolution

To resolve the issue, complete the following steps:

  1. Enter PowerShell command line interface on Delivery Controller (Controller).
  2. Enter “asnp Citrix*” to verify the Citrix cmdlets are available.
  3. Run the following command:
    • Get-BrokerSite.
    • (Check if the value for TrustRequestsSentToTheXmlServicePort results False)
  4. Run the below command.
    • “Set-BrokerSite -TrustRequestsSentToTheXmlServicePort $true”
  5. Run the following command to verify the trusts are set to True:
    • “Get-BrokerSite”
  6. Check the line “TrustRequestsSentToTheXmlServicePort=TRUE”
At this stage, Virtual Delivery Agent (VDA) must allow pass through authentication and start.

Problem Cause

The errors occur because the XML Service does not (by default) trust the requests that are sent without explicit authentication.

Ensure that the Broker logging is correctly configured. Invalid syntax in the configuration file might cause connectivity issues CTX127492 - How to Enable the Controller Service Logging Feature of XenDesktop 5.

Issue/Introduction

This article provides resolution to the error - “An error occurred while making the requested connection”.

Additional Information

CTX200157 - How to Configure Citrix Receiver Pass-Through Authentication for StoreFront or Web Interface
CTX130265 - How to Configure Pass-through Authentication for Smart Cards for XenDesktop
CTX133320 - Citrix Desktop Broker Service Unable to Execute XML Transactions