Error: "No device license is currently available for this computer" on Citrix Provisioning service

Error: "No device license is currently available for this computer" on Citrix Provisioning service

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Article ID: CTX132198

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Updated On:

Description

When launching a session to the PVS target the following error message appears: “No device license is currently available for this computer. A system shutdown will be initiated in 720 hours. To avoid loss of data, save your work now and close all the applications.”

In the PVS console, the Target Device Properties status tab reports no license information, as displayed in the following screenshot:

Resolution

  1. Verify the licenses are reflected on the license server and that the license file includes the right increments: 
    1. For server operating system targets, ensure the license file increment begins with INCREMENT PVS_STD_CCS
    2. For desktop operating system targets, ensure the license file increment begins with INCREMENT PVSD_STD_CCS
    3. For Citrix provisioning service license type cloud, ensure the license file increment begins with PVS_CCLD_CCS

Note: PVS 7.18 release introduces a new license type (PVS_CCLD_CCS) providing support for XenApp and Xen-Desktop Service in Citrix Cloud. 

    1. The Cloud license type applies to the Desktop and the Server Operating Systems that service Citrix Provisioning target devices.
    2. Cloud Citrix Provisioning Service license type requires an on-premises license server and compatible licenses.
    3. The PVS for Apps and Desktops licenses must be installed to select the license type as ‘Cloud’ on the License Server page.
  1. For Universal Hybrid Multi-Cloud License (UHMC) or Platform License (UPL);
    1. The license file will contain PVS_CCS and PVSD_CCS licenses which are on-premises universal licenses.
    2. To configure the new licenses, run the Configuration Wizard to change the license type from Cloud to On-premises on the PVS console.

       

  1. Troubleshooting for licenses not recognized or PVS not contacting the license server:
    1. Upgrade the Citrix license server to the latest version. An outdated license server may cause compatibility issues or licensing errors. If the error persists, proceed to the next step.
    2. Re-download the Citrix licenses, install them accordingly, and remove the old license files.
    3. Right-click the farm from the left-hand pane on the PVS console, click properties, and select ‘Licensing’. Add an invalid hostname in the box and save the changes.
    4. Restart the PVS Stream Service on all PVS servers and Citrix Licensing services on the License server.
    5. Go to the Licensing section in the farm properties within the PVS console to add the valid hostname and save the changes.
    6. Make sure to choose the appropriate license type on the PVS console based on the installed licenses.
      • For CVAD, standalone PVS, and Universal Hybrid Multi-Cloud or Platform Licenses, the license type should be ‘On-Premises
      • For DaaS-based cloud licenses, the license type should be ‘Cloud
    1. Restart the PVS Stream service on all the Provisioning Servers and the Citrix Licensing service on the License Server.
    2. Launch the PVS console and confirm if the licenses were successfully acquired.
    3. If the issue persists, reboot all the PVS servers.

 

Additional Resources

 


Problem Cause

  • Un-synchronized licenses can cause this behavior. If the licenses are correctly synchronized, the Provisioning Services (PVS) listed on the License Administration Console will show an active Subscription Advantage date on the license server. 
  • If the license file does not have the correct increment for the target device operating system, the PVS server will be unable to check out a license for the target.

Issue/Introduction

This article provides resolution to the error "No device license is currently available for this computer."