Desktop Viewer Toolbar Affects XenApp Published Desktops Using StoreFront Services Receiver for Web Only

Desktop Viewer Toolbar Affects XenApp Published Desktops Using StoreFront Services Receiver for Web Only

book

Article ID: CTX131867

calendar_today

Updated On:

Description

Users may experience various issues with the Citrix Desktop Viewer Toolbar functionality, when using StoreFront Services Receiver for Web to access XenApp published desktops.

Note: The Desktop Viewer is now supported in XenApp 6.5 and XenApp 7.x with Receiver 4.x.
         Using XenApp Services support url (pnagent url) is not affected by this 
         Receiver for Web includes the use of Receiver for HTML5 as well

Resolution

The StoreFront Services Receiver for Web configuration can be modified as follows to disable Desktop Viewer Toolbar:

  1. Log on to StoreFront Services server.

  2. Open C:\inetpub\wwwroot\Citrix\StoreWeb\web.config with Notepad.

  3. Change showDesktopViewer="false".

  4. Save the changes.


Problem Cause

This issue may occur if the Citrix Desktop Viewer Toolbar was enabled on the StoreFront Services Receiver for Web. The Desktop Viewer Toolbar is not recommended for use with XenApp published desktops as it causes numerous issues. The Citrix Desktop Viewer Toolbar was designed specifically for use with XenDesktop only.

Issue/Introduction

This article provides resolution when users experience issues with the Citrix Desktop Viewer Toolbar functionality, when using StoreFront Services Receiver for Web to access XenApp published desktops

Additional Information

CTX119784 - Issues with the Desktop Viewer Toolbar Functionality when Using the Citrix Desktop Receiver to Access XenApp Published Desktops

CTX126894 - Multi-Monitor Published Desktop Session on XenApp 6 Appears as Single Monitor Session