Provisioned XenApp Servers Stop Accepting Connections which are Restarted When the License Server is Unavailable

Provisioned XenApp Servers Stop Accepting Connections which are Restarted When the License Server is Unavailable

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Article ID: CTX131202

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Updated On:

Description

Restarted provisioned XenApp servers stop accepting connections when the License Server is unavailable; servers might show a load of 20000.

Requirement

License Server 11.6.1 or later

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

Complete the following steps to resolve the issue:

  1. Install XA600W2K8R2X64R01 hotfix on XenApp 6 servers. XenApp 6.5 servers do not require a hotfix.

  2. Set the following registry value to a file share location with a UNC Path on the XenApp 6 or 6.5 Server Image:
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\Install\CacheLocation
    (CacheLocation is Type:REG_SZ)

  1. Create the file share with the following NTFS permissions.
    Note: In this example, the XA6LIC is the XenApp Server Computer Account not the Citrix License Server.
     User-added image

  2. Set the following Share Permissions.
    User-added image

 

Problem Cause

The root cause for this problem is that the license server cache file MPS-WSXICA_MPS-WSXICA.ini is saved in the install directory \program files (x86)\Citrix\system32\cache and that might be unavailable when the server image is shut down.

Issue/Introduction

This article contains information to restart provisioned XenApp Servers and accept connections when the License Server is unavailable.