Error: "Failed to Retrieve Data: Machine Unresponsive or Reported an Error (Error Code 105)"

Error: "Failed to Retrieve Data: Machine Unresponsive or Reported an Error (Error Code 105)"

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Article ID: CTX131197

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Updated On:

Description

Some virtual machines in XenDesktop 5 infrastructure might not be able to provide WinRM information in the Desktop Director console.
The user of Desktop Director instead notices the following error indicating that the desktop machine is unavailable:

“Failed to retrieve data: Machine unresponsive or reported an error (error code 105). View server event logs for further information.”

User-added image

Resolution

To resolve the issue, delete and recreate the WinRM listener as follows:

winrm delete winrm/config/listener?Address=*+Transport=HTTP
winrm create winrm/config/listener?Address=*+Transport=HTTP

Problem Cause

After troubleshooting the problem from CTX125243 - Enabling WinRM for Desktop Director, it was noticed that when using the netstat – another 5985 port was not listed. WinRM 2.0 listener uses the port 5985 to communicate with the broker. When trying to create WinRM listener with the command, it fails with the following error message:

“Error number: 2144108493 0x80338033

The WS-Management service cannot create the resource because it already exists.”

It appears that the WinRM listener has been corrupt.

Issue/Introduction

This article provides a resolution to the XenDesktop erro Failed to Retrieve Data: Machine Unresponsive or Reported an Error (Error Code 105)

Additional Information

CTX125243 - Enabling WinRM for Desktop Director