Error: "503 Service Unavailable" Appears on Web Interface on the Cloned XenApp Server

Error: "503 Service Unavailable" Appears on Web Interface on the Cloned XenApp Server

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Article ID: CTX131137

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Updated On:

Description

Extensible Transformation Engine (XTE) Service connection fails on cloned server and opening the Web Interface gives the “503 Service Unavailable” error.

The following event log entry is also observed in the cloned server:

Log Name: Application
Source: Microsoft-Windows-IIS-W3SVC-WP
Event ID: 2307
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Description:
The worker process for application pool 'CtxScriptsPool' encountered an error 'Failed to decrypt attribute 'password'  trying to read configuration data from file '\\?\C:\inetpub\temp\apppools\CtxScriptsPool.config', line number '150'. The data field contains the error code.
Log Name:      System
Source:        Microsoft-Windows-WAS
Date:         
Event ID:      5203
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:     
Description:
A process serving application pool 'CitrixWebInterface5.3.0AppPool' reported a failure trying to read configuration during startup. The process id was xxx.  Please check the Application Event Log for further event messages logged by the worker process on the specific error.  The data field contains the error number.

Environment

The above mentioned sample code is provided to you as is with no representations, warranties or conditions of any kind. You may use, modify and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that (a) the sample code may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the sample code fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the sample code. In no event should the code be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SAMPLE CODE, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. Although the copyright in the code belongs to Citrix, any distribution of the sample code should include only your own standard copyright attribution, and not that of Citrix. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the sample code.

Resolution

Workaround 1

To resolve this issue, complete the following steps before running the SysPrep tool:

  1. After installing XenApp 6, do not configure XenApp 6.

  2. Download DeleteNode (see attachment), and save it in any location, for example, C:\Program Files (x86)\Common Files\Citrix\.

    Note: This Script creates a backup of the applicationHost.config file with the extension .citrix_bak in the same location.

  1. Open the C:\Windows\System32\sysprep\unattend.xml file.

  2. Under the node <component name="Microsoft-Windows-Shell-Setup"> in the .xml file, which is present under the node <settings pass="oobeSystem">, add the following snippet:

    <FirstLogonCommands>
            <SynchronousCommand wcm:action="add">
                    <CommandLine>C:\PostSetup.bat</CommandLine>
                    <Description>runs post setup commands that finalize the system</Description>
                    <Order>1</Order>
            </SynchronousCommand>
    </FirstLogonCommands>
  3. Create the C:\PostSetup.bat file. This file contains the commands that must run after the first logon.

    Note: The PostSetup.bat file is mentioned in the node <CommandLine> in Step 4. You can use any valid file name for this batch file within any location.

  4. Add the following lines to the PostSetup.bat file, to execute the VB Script and restart the Internet Information Services (IIS):
    Note: This file can contain other commands apart from the following commands:

    cscript "C:\Program Files (x86)\Common Files\Citrix\DeleteNode"
    iisreset

  5. Run the SysPrep tool.

Workaround 2

To resolve this issue, complete the following steps after running the SysPrep tool:

  1. Download DeleteNode (see attachment).

  2. Extract the .vbs file and copy it to C:\Program Files (x86)\Common Files\Citrix.

  3. Run the following command from the command prompt:
    cscript "C:\Program Files (x86)\Common Files\Citrix\DeleteNode"

  4. Restart IIS or run the iisreset command.

Workaround 3

To resolve this issue, complete the following steps after running the SysPrep tool:
  1. Copy the C:\Windows\System32\inetsrv\config\applicationHost.config file to another location before updating this file.

  2. Open the C:\Windows\System32\inetsrv\config\applicationHost.config file.

  3. Locate the <configProtectedData> node.

  4. Delete the node from <configProtectedData> to </configProtectedData>.

  5. Save the file.

  6. Restart IIS or run the iisreset command.


Problem Cause

This error might occur because the IIS 7 does not function correctly when the Microsoft SysPrep process is active.

Issue/Introduction

This article discusses about the "503 Service Unavailable" error.

Additional Information

The HTTP status code in IIS 7.0, IIS 7.5, and IIS 8.0