Cannot Connect Session Previously Disconnected From Receiver Linux

Cannot Connect Session Previously Disconnected From Receiver Linux

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Article ID: CTX131030

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only.
 
Non-admin users must contact their company's Help Desk/IT support team and can refer to CTX297149 for more information.

 

When the user tries to reconnect the session that was previously disconnected for Linux from Citrix Receiver, the following message is displayed and then the session cannot be reconnected:

“You have exceeded the concurrent connection limit. Please contact your system administrator”

Note: According to the policy, the users and the applications have limited access to a session.

Resolution

You can resolve this issue by completing any of the following two options:

Using Citrix XenApp View in Receiver Linux

Citrix XenApp - Citrix XenApp enables the users to connect to the published resources, such as the published applications, desktops, and published content through a server running the XenApp Services site.

  1. Configure the receiver to point to XenApp services site.

  2. Select Prompt user from Logon mode, as displayed in the following screen shot:
    User-added image

  3. Enter the login credentials for authentication on the receiver rather than on the Windows Logon, such as Username, Password, and Domain, as displayed in the following screen shot:
    User-added image

Note: The advantage of logging in to the Receiver is that, after successful authentication, all the disconnected session starts automatically so that there is no need to authenticate again.

Using Citrix Connection View in Receiver Linux

Connections - Configures the connections between the Citrix Receiver for Linux and the XenApp servers.

Provide the credentials at the published application properties to use the Citrix Connection, as displayed in the following screen shot:
User-added image


Problem Cause

You can configure the Receiver Linux client to access the XML brokers’ servers directly without authentication. The user can view published application/desktop. The users are prompted for credentials, such as the User ID and Password while logging on to published application /desktop.

With this configuration in the Receiver Linux client and with limitation of one session per user in the farm, the message about the exceeded connection limit is displayed to the user. The reconnect session process uses the User ID (SID) as the search criteria to retrieve all connected and disconnected sessions in the entire farm. It is also possible to query the data collector to find the least loaded server and redirect the user to this server, which presents the logon screen.

The error message is not displayed to the user with this configuration if the least loaded server that was redirected to the user is the server that has the user’s previous disconnected session.

Issue/Introduction

This article explains how to fix the error “You have exceeded the concurrent connection limit. Please contact your system administrator”.

Additional Information

CTX108846 - Error: You have exceeded the concurrent connection limit. Please contact your system administrator