Troubleshooting XenDesktop Inter-Service Communication Issues

Troubleshooting XenDesktop Inter-Service Communication Issues

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Article ID: CTX130769

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Updated On:

Description

When one XenDesktop service wants to communicate with another, the requesting service queries the database for the target service WCF endpoint address. If the database is temporarily unavailable when the query is submitted, the requesting service might not be able to locate the target address.

Background

Inter-service communication issues can present a varied number of symptoms depending upon the action in progress when the service endpoint address is requested. The following is a list of common symptoms:
When creating or updating a catalog of Virtual Desktop Agents (VDAs) provisioned using Machine Create Services (MCS), an error is displayed in Desktop Studio indicating “There are no master images associated with this catalog” and the following events are found in the Windows Application event log:

Source: CitrixHostService
Event ID: 1015
Level: Error
Description:
Update of shared key failed with: System.ArgumentException: Service list empty
Parameter name: services Source: CitrixADIdentityService
Event ID: 1015
Level: Error
Description:
Update of shared key failed with: System.ArgumentException: Service list empty
Parameter name: services

Resolution

Verify there are no networking or performance issues with the SQL server hosting the XenDesktop database. A review of the Windows event logs on the SQL server might prove helpful in identifying possible issues.

Run the XenDesktop Service Checker tool to verify all service instances are properly registered (see CTX133767 - XenDesktop Site Checker).


Problem Cause

Inter-service communication has failed because the requesting service is unable to retrieve the target service endpoint address from the database.

Issue/Introduction

This article has information on troubleshooting XenDesktop inter-service communication issues.

Additional Information

CTX133767 – XenDesktop Site Checker

CTX128057 – Getting Started with PowerShell in XenDesktop 5

CTX127254 – XenDesktop 5.6 SDK Cmdlet Help