Errors: "Failed to Snapshot", "VSS_E_VOLUME_NOT_SUPPORTED"

Errors: "Failed to Snapshot", "VSS_E_VOLUME_NOT_SUPPORTED"

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Article ID: CTX130702

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Updated On:

Description

When attempting to build an image from a Windows7 or Server 2008 Virtual Machine (VM) with Imaging Wizard or P2PVS, the following error message is displayed:

"Failed to Snapshot"

Imaging Wizard/P2PVS log shows the following error message:

"VSS_E_VOLUME_NOT_SUPPORTED" and terminates with an error message “Failed to Snapshot” referencing error code 0x8004230c.

Resolution

To enable and start Volume Shadow Copy and Microsoft Software Shadow Copy Provider services, complete the following steps:

  1. Open Control Panel.

  2. Click Classic View in the Tasks pane.

  3. Double-click Administrative Tools.

  4. Double-click Services.

  5. Locate and double-click Microsoft Software Shadow Copy Provider.

  6. In the Startup Type menu, select Automatic or Manual.

  7. Click Start.

  8. Click Apply or OK.

  9. Locate and double-click the Volume Shadow Copy service.

  10. In the Startup Type menu, select Automatic or Manual.

  11. Click Start.

  12. Click Apply or OK.


Problem Cause

Imaging Wizard and P2PVS require the source virtual machine to have both Volume Shadow Copy and Microsoft Software Shadow Copy Provider services enabled to perform an imaging operation. If either or both of Volume Shadow Copy and Microsoft Software Shadow Copy Provider services are set to Disabled, the imaging operation fails.

Issue/Introduction

This article provides a resolution to the errors "Failed to Snapshot" and "VSS_E_VOLUME_NOT_SUPPORTED".