Error: "The Network Connection to your Application was Interrupted. Try to Access your Application Later, or Contact your Help Desk."

Error: "The Network Connection to your Application was Interrupted. Try to Access your Application Later, or Contact your Help Desk."

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Article ID: CTX130370

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Updated On:

Description

When a user attempts to shadow a session, the following error message is displayed:

β€œThe network connection to your application was interrupted. Try to access your application later, or contact your help desk.”

HS-TSDC1 Desktop ERROR

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

To resolve this issue, complete the following procedure:

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

  1. Create a registry entry on the shadower.

  1. Specify the value of REG_SZ in the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\Thinwire3.0; Tw2CachePower with a value of 24. If 24 does not work, try 25.

Notes:

  • Memory of 2^24 bytes can be allocated if cache power of 24 is used.
  • TW2CachePower specifies, the size of the ThinWire cache in powers of 2 bytes

  • A TW2CachePower value of 23 creates an 8MB (2^23 bytes) ThinWire cache. Specify a value in the range, 19 to 25. Any value less than 19 is reset to 19; any value greater than 25 is reset to 25. If you do not specify a value, the ThinWire driver automatically computes the initial size based on connection resolution and color depth, applying a value in the range of 22 to 25. If the required memory space cannot be allocated, the value is gradually lowered until it matches the actual amount of available memory space. If memory space equivalent to a value of 19 (512KB) cannot be allocated, the connection is terminated.


    Problem Cause

    This error may occur if there is not enough Thinwire cache available to shadow a session. The user shadowing the session does not have enough memory allocated for shadowing the session.

    Issue/Introduction

    This article provides resolution to the error: The network connection to your application was interrupted. Try to access your application later, or contact your help desk.

    Additional Information

    CTX115648 – Error: "The Network Connection to your Application was Interrupted" on ICA Client

    CTX121573 – Users are Unable to Connect through ICA when Using Custom Legacy Virtual Channels