Delay in Displaying the Print Dialog Box and Failure in Printing

Delay in Displaying the Print Dialog Box and Failure in Printing

book

Article ID: CTX129985

calendar_today

Updated On:

Description

Following are a few symptoms related to printing experienced by some applications:

  • There is a delay in displaying the printer selection dialog box.
  • Some applications fail to print.
  • There is an increase in the list of printers in HKCU\Software\Microsoft\Windows NT\CurrentVersion\Devices key.

    Resolution

    Microsoft has released the following two hotfixes to address this issue:
    • KB2620656 - Invalid redirected printers might be available in a Remote Desktop Services session that connects to a RD Session Host server running Windows Server 2008 or Windows Server 2008 R2.
    • KB2532459 - Print queue does not work if the queue is not one of the first 100 queues installed in a Windows Server 2008 or Windows Server 2008 R2 Terminal Services session.

      Problem Cause

      Change in permissions related to AddPrinter type functions in Windows Server 2008 and Windows Server 2008 R2 causes the client printers to populate and remain in the HKCU\Software\Microsoft\WindowsNT\CurrentVersion\Devices key, even after the user logs off.

      With some applications, the following issues can be experienced because of the increase in the number of printers in the HKCU\Software\Microsoft\Windows NT\CurrentVersion\Devices key:
      • Negative performance when a user selects a printer from the Print dialog box.
      • Delay in the logon procedure.
      • Failure in printing after 100 printer ports are created. This issue occurs because of a hard coded limit in the operating system.

        Issue/Introduction

        This document contains information about a change in Windows Server 2008 and 2008 R2 printing functions that adversely affect some applications