XenApp Error: The Citrix WMI Service terminated with the following error: Access is denied
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Article ID: CTX129081
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Updated On:
Description
The Citrix WMI service is set to Manual by default in XenApp 6 Fundamentals but trying to start it manually fails with the error Event ID 7023:
“The Citrix WMI Service terminated with the following error: Access is denied.”

There might be a series of warnings with Event ID 3 on the Application log as shown in the following screen shot:

An event was logged for each of the Citrix WMI dll files listed in the subkeys of the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\WMIService\DLLs
The description reads:
“The license check for <name of dll> failed, it will therefore not be available until a valid license is provided.”
An examination of the license file shows that it is valid. The Licensing node in QuickStart console also shows that licensing was properly configured.
Environment
The above mentioned sample code is provided to you as is with no representations, warranties or conditions of any kind. You may use, modify and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that (a) the sample code may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the sample code fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the sample code. In no event should the code be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SAMPLE CODE, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. Although the copyright in the code belongs to Citrix, any distribution of the sample code should include only your own standard copyright attribution, and not that of Citrix. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the sample code.
Resolution
To resolve this issue disable the Citrix WMI Service because it is not used.
Problem Cause
This error occurs because Citrix WMI service is only used in Enterprise and Platinum Editions of XenApp and not used in XenApp Fundamentals.
Issue/Introduction
This article provides resolution when the Citrix WMI service fails with Error event ID 7023: “The Citrix WMI Service terminated with the following error: Access is denied."
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