Network Level Authentication Required for Remote Desktop Connections After Installing XenApp 6.x

Network Level Authentication Required for Remote Desktop Connections After Installing XenApp 6.x

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Article ID: CTX128857

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Updated On:

Description

The following error occurs after installing XenApp 6.x with the meta-installer, using the Graphic User Interface (GUI) or the command line:

“The remote computer requires Network Level Authentication, which your computer does not support. For assistance, contact your system administrator or technical support.”

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Network Level Authentication (NLA) is recommended, however RDC client versions earlier to version 6.1, do not support NLA.

Resolution

Complete the following installation steps to resolve the error:

Pre-installation Steps to Prevent the Requirement of NLA

The default installation of Remote Desktop Services (RDS), using ServerManager, does not require NLA. Installing RDS prior to running the XenApp 6 meta-installer prevents the requirement of NLA.

This can also be done using the following PowerShell commands:
PS > Import-Module ServerManager

PS > Add-WindowsFeature RDS-RD-Server

Restart after adding the RDS role.

Post-installation Steps to Disable NLA

  1. To disable NLA, launch ServerManager.

  2. Navigate to Roles > Remote Desktop Services > RD Session Host Configuration.

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  1. Right-click on the RDP-Tcp connections to open a Properties window.

  2. Under the General tab, clear the Allow connections only from computers running Remote Desktop with Network Level Authentication check box.

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Problem Cause

This error may occur if NLA is required.

Issue/Introduction

This article documents options for disabling or preventing a requirement for Network Level Authentication for Remote Desktop Connections to XenApp 6 servers.