Receiver Connection Fails After Installation Using Run As

Receiver Connection Fails After Installation Using Run As

book

Article ID: CTX128385

calendar_today

Updated On:

Description

Hosted applications fail to open after installing the Citrix Windows client using the Run As option. The session fails to complete and does not show an error message.

Resolution

Citrix recommends using the DONOTSTARTCC=1 command line switch with the Citrix client installer when deploying with Active Directory, GPO, SCCM, or Citrix Receiver. The recommendation prevents Connection Center from opening, which in turn prevents wfcrun32 from opening until a user tries to initiate a session.


Problem Cause

The wfcrun32 process continues to run in the installation user’s context when the installation is complete. Connection Center initiates the wfcrun32 process, which starts after installation. Users cannot open applications until wfcrun32 runs in applications context.

In the following image, TestUser is the logon account and has lowered privileges. The client was installed using the Run As option with an Administrator account. After the installation, the wfcrun32 process is running in the Administrator account that prevents TestUser from accessing hosted applications.

Windows Task Manager

Note: This situation can occur if an enterprise software delivery system is used to deliver the client with elevated credentials used during the installation.

Issue/Introduction

This article provides an explanation for the issues when opening the potential application after installation with an enterprise deployment system.