Published Application Fails to Appear

Published Application Fails to Appear

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Article ID: CTX128009

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Updated On:

Description

When publish seamless applications the following symptoms are observed:

  • This issue can happen with any published application but not to published desktops.
  • The session initially begins to connect as expected. After the loading, the dialog box disappears and the explorer application fails to appear.
  • If the session is viewed in the Studio / Director console while the application is loading, it initially shows as connecting, and later shows as disconnected, until finally the session disappears.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

The following are the two methods to resolve this issue.

Disclaimer
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Method 1 (Recommended)

As a workaround on the XenApp Server\VDAs Servers use the following registry key to increase the time-out:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\wfshell\TWI

Value Name: ApplicationLaunchWaitTimeoutMS
Type: REG_DWORD
Data (decimal): <required additional time-out, in milliseconds>  (Example 60seconds=60000milliseconds)

Note:

  • Set this value using Decimal.
  • By default there is a 60000 millisecond (1 minute) timeout when launching an application.  
  • Specifying a value less than 10000 reverts to 10000 because 10 seconds is the minimum override.
  • This value is also available as a Policy [Application Launch Wait Timeout] setting.
  • Any value set via policy will override the value set in the registry of the VDA.
 
Studio 

 
Citrix Cloud 
Application Launch Wait Timeout
 

 
Method 2

On the XenApp Server\VDAs Server use the following registry change to set the length of time a client session waits before disconnecting the session.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\wfshell\TWI

Value Name: LogoffCheckerStartupDelayInSeconds
Type: REG_DWORD
Data (Decimal): An integer that denotes the time to wait for the application to start

Note:

  • The registry setting written above doesn't work anymore in CVAD7.15 and later.
    You need to configure via Policy [Logoff Checker Startup Delay] in CVAD7.15 and later.
Studio 
Logoff Checker Startup Delay

Citrix Cloud 
Logoff Checker Startup Delay
 
  • Setting this value also increases the time it takes for a user to log off the server.
  • Doubled value is used for wait time. For example, if 10 seconds are set, the wait time is 20 (10 x 2) seconds.

Enter the delay time in seconds, up to 10 minutes (600 seconds). It is more useful as a troubleshooting step to confirm that the issue is because of the length of time required for the application to launch. Once it is identified that the application is taking more time to launch, troubleshoot from slow perspective if required.


Problem Cause

The issue occurs when the default one-minute time-out is exceeded and the session exits automatically. The Published application takes longer time to start as it is integrated into the Windows shell.

Issue/Introduction

This article provides resolution when explorer.exe fails to launch.

Additional Information