Administrators Cannot Recreate the ICA Listener on a XenApp Server for Windows 2008
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Article ID: CTX127956
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Updated On:
Description
When the ICA-listener on a XenApp Server is deleted, administrators cannot create a new listener. An ICA listener is unavailable and the following error message is displayed:
“Unable to create connection:”

Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
To recreate the ICA listener, complete the following steps:
Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.
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Restore the following registry key from another server that is not altered.
HKEY_ LOCAL _ MACHINE\SYSTEM \CurrentControl Set\Control\Terminal Server\WinStations\ICA-Tcp

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Restart the server, the ICA-tcp listener appears in the Terminal Services Configuration console.
Problem Cause
This issue is caused by the underlying operating system.
Issue/Introduction
This article contains information for administrators to recreate the ICA Listener on XenApp 5 for Windows 2008.
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