Error 9009: The Desktop Window Manager has exited with code (0x40010004)

Error 9009: The Desktop Window Manager has exited with code (0x40010004)

book

Article ID: CTX127883

calendar_today

Updated On:

Description

Sometimes when connecting to a seamless published explorer application (IExplorer.exe or Explorer.exe) on XenApp 6.x server, the published explorer displays a pop-up for half a second and then closes.

Application Event log reports an error ID: 9009 Source: Desktop Window Manager (The Desktop Window Manager has exited with code (0x40010004).

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Solution 1

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

To resolve the issue, add a 10-second delay to the client session as follows so that the client waits for the published explorer to start before disconnecting the session:
Open REGEDIT:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\Wfshell\TWI
Name: LogoffCheckerStartupDelayInSeconds
Type: REG_DWORD
Value: Set the value of 10 seconds to this key

Solution 2

  1. Uninstall the XenApp Server role

  2. Uninstall the VMWare Tools

  3. Install the latest VMWare Toools

  4. Install the latest XenApp version


Problem Cause

This error can occur if the Citrix Receiver needs more time to establish the ICA session due to network or server resource issues

Issue/Introduction

This artcile provides a resolution to the error "Error 9009: The Desktop Window Manager has exited with code (0x40010004)".

Additional Information

CTX101644 - Seamless Configuration Settings
CTX235513 - VMware vSphere 6.7 - Citrix Known Issues