Error: "Paper size 1 is not a valid paper size"

Error: "Paper size 1 is not a valid paper size"

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Article ID: CTX127223

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Updated On:

Description

When trying to save a policy that contains session printer settings, you receive the following error message:
“Paper size 1 is not a valid paper size”.

Also, there is a delay in opening these policies.

Resolution

A hotfix is available and is included in the new XenApp Printing Optimization Pack. Refer the following links for installation instructions.

Hotfix DSCXAGPMx100WX64001 - For Citrix Delivery Services Console for XenApp Group Policy Management for Windows x64 - English
XenApp Printing Optimizations

Workaround

Check if the 64-bit drivers for Windows Server 2008 R2 are loaded on the print server.

Complete the following steps to check if the 64-bit drivers for Windows Server 2008 R2 are loaded on the print server:

  1. Right-click on the printer and select Properties.

  2. Select the Sharing tab.

  3. Click Additional Drivers.

  4. Select the x64 check box.

Test the printer from the XenApp server.

Complete the following steps to test the printer:                     

  1. Select Start > Run.

  2. Type \\<Print Server Name> and click OK.
    Example: \\PRINTERS

  3. Right-click on the desired printer and select Connect from the context menu.
    Once the printer connects and is able to print from the server, the policy issue should be resolved.


Problem Cause

This is an underlying Point and Print issue. This might be caused by 64-bit printer drivers not being added under Sharing > Additional Drivers, or incompatibilities between the 32-bit and 64-bit printer drivers. A common cause is that a driver on the print server does not have a 64-bit version or is not compatible for Windows Server 2008 R2.

Issue/Introduction

This article contains resolution to the error "Paper size 1 is not a valid paper size".

Additional Information

Citrix XenApp Printing Optimization Pack for Citrix XenApp 6.0.