Internal Error 2869 when Installing Hotfixes on XenApp 6.x

Internal Error 2869 when Installing Hotfixes on XenApp 6.x

book

Article ID: CTX127124

calendar_today

Updated On:

Description

Errors occur when installing hotfixes on a XenApp 6.0 server using the manual method. The manual installation method included:

  • Right-clicking on the .msp hotfix package and selecting Apply

  • Double-clicking on the .msp hotfix package

The error displayed is a message box with the following dialog:

Internal Error 2869. ErrorDialog

Failures would occur with console/physical server connections and RDP/Terminal Services client connections.
 

A review of the Windows Installer logs generated show the following entries:

CTX_SIDLookup failed with error code 1627
CustomAction CTX_SIDLookup.655CCDD2_63F2_4973_9D14_52C912BFB0E2 returned actual error code 1603 but will be translated to success due to continue marking
Action ended 15:52:01: CTX_SIDLookup.655CCDD2_63F2_4973_9D14_52C912BFB0E2. Return value 1.
MSI (c) (50:84) [15:52:01:043]: Doing action: ErrorUACEnabledAndHotfix
Action 15:52:01: ErrorUACEnabledAndHotfix.
Action start 15:52:01: ErrorUACEnabledAndHotfix.
MSI (c) (50:84) [15:52:01:044]: Note: 1: 2235 2: 3: ExtendedType 4: SELECT `Action`,`Type`,`Source`,`Target`, NULL, `ExtendedType` FROM `CustomAction` WHERE `Action` = 'ErrorUACEnabledAndHotfix'
MSI (c) (50:84) [15:52:01:044]: Transforming table Error.
MSI (c) (50:84) [15:52:01:044]: Transforming table Error.
MSI (c) (50:84) [15:52:01:044]: Note: 1: 2262 2: Error 3: -2147287038
MSI (c) (50:84) [15:52:01:045]: Transforming table Error.
MSI (c) (50:84) [15:52:01:045]: Transforming table Error.
MSI (c) (50:84) [15:52:01:045]: Note: 1: 2262 2: Error 3: -2147287038
MSI (c) (50:64) [15:52:01:046]: Transforming table Error.
MSI (c) (50:64) [15:52:01:046]: Transforming table Error.
MSI (c) (50:64) [15:52:01:046]: Note: 1: 2262 2: Error 3: -2147287038
MSI (c) (50:64) [15:52:01:048]: Transforming table Error.
MSI (c) (50:64) [15:52:01:048]: Transforming table Error.
MSI (c) (50:64) [15:52:01:048]: Note: 1: 2262 2: Error 3: -2147287038
DEBUG: Error 2869: The dialog ErrorDialog has the error style bit set, but is not an error dialog
MSI (c) (50:64) [15:52:01:053]: Font created. Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg
Internal Error 2869. ErrorDialog

Unattended installations work correctly, such as:

Msiexec.exe /update <hotfixname>.msp /passive /norestart

Resolution

There are three resolutions to this issue:

  1. Use an unattended method of installing the hotfix such as:

    Msiexec.exe /update <hotfixname>.msp /passive /norestart
  2. Run a command prompt with elevated administrative rights:

    1. Click on Start > Accessories.

    2. Right-click on the Command Prompt link.

    3. Select Run as administrator.

    4. In the new command prompt window, enter the path and hotfix package name. Press Enter. For example, C:\Temp\XAE600W2K8R2X64002.msp

  3. Log in using the local administrator account to install the hotfix manually.


Problem Cause

This issue occurred because User Account Control was enabled on the server and the user was logged in using a domain account that was in the local Administrators group on the server.

This means the account being used only had protected administrative rights and not elevated (or full) administrative rights.

Citrix hotfix packages contain custom actions and the installer package complies with Microsoft User Account Control (UAC) guidelines, so elevated administrative rights are needed to install hotfix packages on XenApp 6.0 servers.

When manually installing the hotfix, the needed privileges are not in place for a domain account with administrative rights.

Issue/Introduction

This article contains resolution to Internal Error 2869 that occurs when Installing Hotfixes on XenApp 6.x.

Additional Information

MSDN - User Account Control information

See the Installing and Uninstalling This Release section of the Citrix hotfix you are installing.