MFCOM Errors During Discovery Process in the Access Management Console for Custom Citrix Administrators

MFCOM Errors During Discovery Process in the Access Management Console for Custom Citrix Administrators

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Article ID: CTX126977

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Updated On:

Description

Custom Citrix Administrative Users see an MFCOM Service error when running the discovery process on the Management Console:

“Errors occurred when using <server name> in the discovery process.

An unexpected error occurred. Check that the server name is correct, that the server is on, that Citrix XenApp is installed on this server, and that the Citrix MFCOM Service is running.”

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“Errors occurred when using <server name> in the discovery process.

Citrix MFCOM Service did not respond as expected. Make sure that your account is a member of this computer’s Distributed COM Users group if you are connecting to a remote server. Check the version of Citrix XenApp on the computer and make sure that a compatible version of Citrix MFCOM Service is installed and running.”

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Resolution

There are multiple possible causes for this issue. Following are the most common causes and the appropriate resolutions:

Cause 1

The account used to run discovery is not an Citrix Administrator. Error: "You must be a Citrix Administrator to perform this action"

Resolution 1

Use DSView to check all the Administrators of the farm and use another Citrix Admin credentials to launch AppCenter.
Once launched, you can change it to any user as per your requirement.

Cause 2

The user is not a member of the Distributed COM Users group on the server:

Resolution 2

Add the user to the BUILT-IN\Distributed COM Users group on the server that you are connecting to. The recommendation is to do this using nested groups, such as Citrix Admins group.

Cause 3

The users do not have View Published Applications and Content permissions configured.

Resolution 3

  1. In the properties of the Citrix Administrator account, go to the Applications section.

  2. Under the node Published Applications, select View Published Applications and Content (on the Applications node and all sub folders).

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Cause 4

An application might contain an invalid character. (Update AppCenter to newest release prevents invalid characters).

Capture a CDF trace while attempting to launch AppCenter or re-run discovery in AppCenter. Check for message entries similar to:

>Inside GetXmlNodesFromXml
>inside LoadXml
>Exception While Loading XML..srtipping non xml chars and retrying..
>'', hexadecimal value 0x1F, is an invalid character. Line 1, position 2428522.
>Inside stripNonValidXMLCharacters
>Failed to call method EnumFarmObjects: Exception has been thrown by the target of an invocation...

If Citrix XenApp 6.5 PowerShell SKD is installed a XenApp server, then use the PowerShell commands (...
Add-PSSnapin citrix.*
get-xaapplication | ft displayname, browsername, enabled -auto
...and review the output of the PowerShell command and identify any application that display unexpected characters. Example output:

DisplayName BrowserName Enabled
----------- ----------- -------
Excel False
Filezilla v3_▼10 Filezilla v3_▼10 True

Note that the Filezilla application includes a unexpected character '▼'. 

Resolution 4

Again if Citrix XenApp 6.5 PowerShell SKD is installed- Use the PowerShell command is used to remove the suspect published application.
remove-xaapplication ("Filezilla v3_" + [char]0x001F + "10")

After removing the application, Citrix AppCenter discover works as expected.

Cause 5

Discovery would fail if a custom administrator has permissions to a nested subfolder but no permissions to the parent folder of that subfolder.

Resolution 5

For discovery to work add atleast the view permission or remove the permissions.

Cause 6

Invalid MFServer entry in database

Resolution 6

Perform DScheck on server. Ensure that a backup of the database has been perform before proceeding. 

Select "Server" > "All Servers"> Check Only" > "Run".

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Review results for any invalid entries

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Once object is found: Select "Delete server from Datastore"> Enter object name > "Run"

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Once object has been deleted, Select "Clean" > "Run".

Cause 7

The account used to run discovery is not an Citrix Administrator. Error: "You must be a Citrix Administrator to perform this action"

Resolution 7

Use DSView to check all the Administrators of the farm and use another Citrix Admin credentials to launch AppCenter.
Once launched, you can change it to any user as per your requirement.

Run DSVIEW
Expand Server Neighborhoods----- Farm Name-----
Admin Tools---------- Users-----------GUID----------
Attribute(click on each attribute GUID)--------Adminfriendlyname

Issue/Introduction

This article provides the three common possible root causes of MFCOM errors encountered when custom admins run a discovery process in the Citrix AMC/DSC.

Additional Information