Client Drives Cannot be Accessed in XenApp Running on VMWare ESX

Client Drives Cannot be Accessed in XenApp Running on VMWare ESX

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Article ID: CTX126188

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Description

When accessing a client drive from an ICA session running on XenApp 6.0 hosted on VMWare ESX, the following error occurs:

“\\Client\C$ refers to a location that is unavailable.”

The client drives are mapped successfully inside the ICA session.

Resolution

When mapping a drive letter to the mapped client drive (with the net use command), the client drive can be accessed correctly. The Shared Folders feature adds a network provider in the following location: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order\

This feature conflicts with the client drive mapping feature of XenApp 6.0 on Microsoft Windows 2008 R2.

To resolve this issue, complete the following steps:

  1. Log off the server sorting the profiles.

  2. From Control Panel, go to Programs and Features.

  3. Select VMWARE tools and select Modify.

  4. Set Shared Folders to Not installed.

  5. Reboot the server.


Problem Cause

The VMware Tools were installed with the Complete option, which installs the shared folders feature in the virtual machine.

Issue/Introduction

This article contains information on how to access client-drives in XenApp running on VMWare ESK

Additional Information

http://communities.vmware.com/servlet/JiveServlet/download/11414-1-31934/Citrix%20on%20VMware%20V2.3.pdf