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Article ID: CTX125761
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Description
XenApp Target Device appears to be unresponsive.
Background
When the Provisioned XenApp server is accessed through the local console, you see a gray blank screen. There are different symptoms reported for the same incident and they are not specific to Provisioning services or XenApp. In some cases, the console does not respond at the screensaver for that Target Device.Though the Target Devices appear to be unresponsive, only certain services on the server have stopped responding. A restart normally gets the Target Device back to service.
Resolution
This is a known issue with Windows 2003 Server Service Pack 1/Service Pack 2. Refer to
http://support.microsoft.com/default.aspx?scid=kb;EN-US;935926
To address this issue caused by incorrect lock inversion, install the following Microsoft Security Update with Quick Fix Engineering (QFE) bits, which has the fix for KB935926: http://support.microsoft.com/default.aspx?scid=kb;EN-US;979683
An example of the switch that enables the QFE bits on Windows 2003 server with Service Pack 2 is WindowsServer2003-KB979683-x86-ENU.exe /B:SP2QFE
Note: This update, with the appropriate switch, must be run again after installing any service pack. To learn more about the difference between GDR and QFE branches of Microsoft Windows Updates, refer to the following links:
Problem Cause
A Windows Server 2003-based computer stops responding when the registry is used extensively. A memory dump or post mortem debug on the computer that does not respond, indicates abnormally high resource contention involving the Microsoft system registry lock,
nt!CmpRegistryLock. Multiple threads belonging to different process spaces trying to access the registry causes derogated system performance and the operating system or application stops responding.
Issue/Introduction
XenApp Target Device becomes unresponsive and displays a gray screen.