CDViewer has Stopped Working with Error: "System.IO.InvalidDataException" When Opening a Saved ICA File

CDViewer has Stopped Working with Error: "System.IO.InvalidDataException" When Opening a Saved ICA File

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Article ID: CTX125727

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Updated On:

Description

When passing an ICA file to wfcrun32.exe from the command line and the ICA file contains the lines:

  • InputEncoding=ISO8859_1
  • ConnectionBar=1

CDViewer.exe version 11.2x might exit with the error system.IO.InvalidDataException.

Resolution

To resolve the issue, edit the ICA file:

  1. Open the ICA file.

  2. Search for the following line in the file:
  3. InputEncoding=ISO8859_1

  4. Replace with the following value:

    InputEncoding=UTF-8

  5. Save the ICA file.


Problem Cause

The issue occurs because of the wrong encoding being specified in the ICA file. Citrix does not use ISO8859_1 encoding with the desktop viewer.

Issue/Introduction

CDViewer has Stopped Working with Error: System.IO.InvalidDataException.