Error: Shadow failed. Error Code 7044 and 120

Error: Shadow failed. Error Code 7044 and 120

book

Article ID: CTX125693

calendar_today

Updated On:

Description

When trying to shadow a session with XenApp 6.0 and later versions, the following error message is displayed to the shadower, if either the shadower or the shadowee is configured to use multiple monitors:

  • Multi-monitor configuration on shadower: “Shadow failed. Error code 120 (Error 120 – This function is not supported on this system.)”

    User-added image

  • Multi-monitor configuration on shadowee: "Shadow failed. Error code 7044 (Error 7044 - The request to control another session remotely was denied.)”

    User-added image

When trying to shadow from one session to another session with a single monitor, shadowing works without issues, the error appears if the shadowee or shadower is using multiple monitors.

Note: The error is not explicit to this issue. This is a general error message that might occur in different scenarios.


Resolution

Remote Desktop Services do not support shadowing multiple monitors, shadowing of ICA sessions is also limited in the same way.

Refer to Microsoft Article ID 2484290 for more information about session shadow with multiple monitors enabled in Windows Server 2008 R2.


Problem Cause

Earlier to Windows 7 or Windows Server 2008 R2, there is no built-in support for multiple monitors in Remote Desktop sessions. With the introduction of multi monitor support in Remote Desktop Services, shadowing is now depending on underlying functionality available in operating system.

Issue/Introduction

This article contains information on session shadow with multiple monitors enabled in Windows Server 2008 R2.

Additional Information

CTX134090 - Shadow Failed. Error Code 120.

Shadowing an RDP session on Windows Server 2008 R2 may fail when Aero is enabled

"Input Capture Window" shows on local desktop when you start Windows Remote Assistance as a RemoteApp