Citrix Licensing Service Unexpectedly Stops When Logging Off the Server Console

Citrix Licensing Service Unexpectedly Stops When Logging Off the Server Console

book

Article ID: CTX125194

calendar_today

Updated On:

Description

The Citrix Licensing service unexpectedly stops on License Server 11.6.1 Build 10007 running on Windows Server 2003, when logging off the server console. This issue occurs when logging off the physical console or logging off RDP session 0 that was established using the /console or /admin switch.

Event ID 7034 is logged in the EventViewer System log, as shown in the following screen shot:

User-added image

Note: This issue occurs only with Citrix License Server 11.6.1 build 10007 on Windows Server 2003. The issue does not occur on Windows Server 2008.

Resolution

This issue is resolved with Citrix License Server version 11.9 and later which can be downloaded here.

Workaround

As a workaround, the recovery option of the Citrix Licensing service can be modified to restart the service when it fails.

To modify the recovery option of the Citrix Licensing service, complete the following procedure:
  1. In the Recovery tab of the Citrix Licensing service, set the response for first, second, and subsequent failures to Restart the Service.

  2. Set the Restart service after option to 0 minutes as shown in the following screen shot: 

    User-added image

Problem Cause

The underlying code of the License Server does not properly handle the Windows logoff function.

Issue/Introduction

The Citrix Licensing service unexpectedly stops on License Server 11.6.1 Build 10007 running on Windows Server 2003, when logging off the server console

Additional Information

Citrix eDocs - License Server Product Documentation