After importing of an OVF package from a VMware environment Virtual Machine Fails to Boot with STOP 7B or 'Device Does Not Exist'

After importing of an OVF package from a VMware environment Virtual Machine Fails to Boot with STOP 7B or 'Device Does Not Exist'

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Article ID: CTX124925

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Updated On:

Description

After importing of an OVF package from a VMware environment, a Windows virtual machine fails with a STOP 0x0000007B error, or a Linux virtual machine does not boot because a device (/dev/sda1 for example) does not exist.

On a Windows virtual machine a STOP 0x0000007B error occurs.

On a Linux virtual machine, it does not boot because a device (/dev/sda1 for example) does not exist.

Resolution

Manually perform the fix-up operation on a VM after the appliance has been imported and the fix-up option was not chosen in the wizard.
To resolve this issue, complete one of the following methods:

Method 1:

Repeat the Appliance Import operation and select the “Run Operating System Fixups” option on the Advanced Options screen of the wizard.

Method 2:

  1. Create a CIFS ISO Storage Repository.

  2. Copy the xenserver-linuxfixup-disk.iso to the Storage Repository.
    The ISO can be found on the XenCenter client machine in the following location:
    C:\Program Files (x86)\Citrix\XenCenter\Plugins\Citrix\XenAppliance\External Tools

  3. The ISO Storage Repository must refresh and list the ISO in XenCenter.

  4. Attach the xenserver-linuxfixup-disk.iso to the virtual machine.

  5. Open the Properties of the virtual machine and in the Startup Options set the DVD-Drive above the Hard Disk. Click OK.

  6. Boot the virtual machine. The virtual machine should boot from the ISO and identify the virtual hard disks of the virtual machine to repair either a Windows or a Linux grub boot loader.

  7. After the fix-up is complete, the virtual machine powers off.

  8. Eject the xenserver-linuxfixup-disk.iso from the virtual machine and boot the virtual machine again.


Problem Cause

The Appliance Import feature of XenCenter includes an option for “fix-up” of an imported virtual machine as part of the import process. This is particularly useful for repairing a virtual machine operating system when the OVF package was built on a hypervisor other than XenServer.

Each hypervisor presents virtual hardware to a virtual machine in a way that appears different to the operation system that runs within the virtual machine. How the operating system within the virtual machine responds to changes in boot device hardware is the basis for the fix-up feature of the Appliance Import.

This most frequently happens if the OVF Package was created from a VMware environment.

Issue/Introduction

After importing of an OVF package from a VMware environment Virtual Machine Fails to Boot with STOP 7B or 'Device Does Not Exist'

Additional Information

CTX140423 - How to Import VMDK Files to XenServer