Unable to Connect to XenDesktop Virtual Desktop Agent on Vista or Windows 7 with WDDM Driver

Unable to Connect to XenDesktop Virtual Desktop Agent on Vista or Windows 7 with WDDM Driver

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Article ID: CTX124877

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Updated On:

Description

When using XenDesktop Virtual Desktop Agent (VDA) on a physical or virtual machine running Vista or Windows 7 with a Windows Display Driver Model (WDDM) video driver, there might be issues connecting to the VDA.

Symptoms to this issue include the following:

  • Unable to connect to the VDA.
  • Connected briefly to VDA then the connection immediately disconnects.
  • Connected but only see a black screen.
  • System Exception (blue screen) on the Virtual Desktop Agent machine.
  • Event ID 43: Windows has stopped this device because it has reported problems.

Environment

This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.

Resolution

To resolve this issue, complete one of the following resolutions: 

Resolution 1

To use WDDM driver on Vista or Windows 7,  refer to XenDesktop HDX 3D Pro. This is supported on physical machines (whether desktop machines or blades or rack workstations). In some cases, this might be a suitable resolution for remote access to physical Windows 7 PCs, with some limitations (for example, host monitor blanking cannot be guaranteed).

Resolution 2

If using a Virtual Machine (VM) or do not want to use HDX 3D Pro, the resolution is to uninstall the WDDM driver from the Vista or Windows physical or VM and install Microsoft SVGA driver.

  1. Open Device Manager from Control Panel and expand Display adapters.

  2. Select the display device using WDDM driver, which would be generally non Citrix Display driver shown in the list. Right-click on it and click Update Driver Software.

  3. Select Browse my computer for driver software.

  4. Select Let me pick from a list of device drivers on my computer.

    If Show compatible hardware is selected, it lists the Standard VGA Graphics Adapter. Otherwise, select Standard VGA Graphics Adapter from the list of drivers shown and and click Next.

    Note: Screen might flicker as the driver gets updated.

  1. Close Device Manager and restart the machine.

    Windows will default to the Standard VGA device.

    After the restart, verify in the Display Adapters (Device Manager from Control Panel) that Citrix Display Driver is enabled and working.


Problem Cause

On Vista and Windows7 with WDDM driver installed, the Citrix XenDesktop VDA cannot load the Thinwire Display Driver, which is based on XPDM. This is a known Vista/Windows 7 limitation. XPDM and WDDM display drivers cannot co-reside; all graphics adapters in a system must use the same display driver model.

As the VDA cannot load the display driver, it would not be able to remote using HDX. XenDesktop 5 adds functionality in the VDA installer to automatically uninstall any WDDM driver during installation and replace it with the Microsoft SVGA driver.

Issue/Introduction

This article contains resolutions to the issues that arises when connecting to the Virtual Desktop Agent (VDA).

Additional Information

XenDesktop HDX 3D Pro (For XenDesktop 4, see the HDX 3D Pro Graphics 1.1 Administrator’s Guide.
CTX124443 - XenDesktop 4 HDX 3D for Professional Graphics 1.1 - Administrator's Guide

Excerpt from Microsoft's MultiMonitor Support and Windows Vista article:

“All graphics adapters in a system must use the same display driver model. That is, all of them should either be running XPDM or WDDM. The driver models are mutually exclusive, and Windows Vista does not allow the simultaneous loading of both an XPDM driver and a WDDM driver. If a system has one graphics adapter with a XPDM driver and another with a WDDM driver, then Windows Vista will choose the POST device, which is the one with VGA resources. This is commonly referred to as the "VGA adapter".

CTX123952 - Unable to Connect to XenDesktop Virtual Desktop Agent on Windows 7 with VMware Tools ESX 4.0 Update 1
Windows Display Driver Model (WDDM)
Wikipedia Article on WDDM
VMware Article: How to switch between SVGAII and WDDM driver