Unable to Connect to XenDesktop Virtual Desktop Agent on Windows 7 with VMware Tools ESX 4.0 Update 1

Unable to Connect to XenDesktop Virtual Desktop Agent on Windows 7 with VMware Tools ESX 4.0 Update 1

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Article ID: CTX123952

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Updated On:

Description

Users are unable to connect to XenDesktop Virtual Desktop Agent on a Windows 7 client that has VMware tools for ESX 4.0 Update 1 installed.

Symptoms include the following:

  • Unable to connect to the Virtual Desktop Agent.

  • Able to connect briefly to Virtual Desktop Agent, then it immediately disconnects.

  • System Exception (blue screen) on the Virtual Desktop Agent machine.

  • Event ID 43: Windows has stopped this device because it has reported problems.

  • Event 9032 when launching the Virtual Desktop Agent:

    Log Name:      Application 
    Source:        Citrix ICA Service 
    Date:          6/10/2010 1:57:22 PM 
    Event ID:      9032 
    Task Category: None 
    Level:         Error 
    Keywords:      Classic 
    User:          N/A 
    Computer:      ***** 
    Description: 
    Citrix ICA could not configure Thinwire and switch to the remote ICA display. Rebooting the workstation or logging in at the console will fix this.

Environment

This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.

Resolution

When installing or upgrading VMware tools, use the Custom Installation option to clear the SVGA 3D Driver under the VMware Device Drivers feature set. If the tools have already been installed, run the installation again and use the repair option to uninstall the SVGA 3D driver, or uninstall it through Device Manager.

Follow the instructions (from VMware) to use the previous SVGA II driver, ensuring that Windows Update does not re-install the WDDM drivers:

  1. Open Device Manager from Control Panel.

  2. Expand the Display Adapters entry.

  3. Right-click on VMWare SVGA 3D (WDDM) and click Properties.

  4. Click Uninstall.

  5. Select Delete the driver software for this device.

  6. Click OK.

    Note: Your screen might flicker as the driver is removed.

  7. Close Device Manager and restart Windows 7.

    Windows defaults to the Standard VGA device.

  8. Open Device Manager, expand Display Adapters.

  9. Right-click Standard VGA and select Properties.

  10. Click Update Driver.

  11. Click Browse my Computer.

  12. Browse to directory C:\Program Files\Common Files\VMware\Drivers\video.

  13. Click Next.

  14. Confirm the driver installation.

  15. Close window and restart.


Problem Cause

VMware tools v4 Update 1 introduces the VMware SVGA 3D WDDM driver as the default display driver when installed on Windows 7 virtual machines. The Citrix Thinwire graphics driver that ICA uses, is an XPDM (Windows XP Display Driver Mode) driver. In Windows Vista and 7, the operating system disables XPDM drivers if a WDDM display driver is present on the system.

Issue/Introduction

XenDesktop issue with Windows 7 VDA running VMware tools for ESX4 Update 1 (WDDM Display Driver)

Additional Information

Excerpt from Microsoft's MultiMonitor Support and Windows Vista article:

"All graphics adapters in a system must use the same display driver model. That is, all of them should either be running XPDM or WDDM. The driver models are mutually exclusive, and Windows Vista does not allow the simultaneous loading of both an XPDM driver and a WDDM driver. If a system has one graphics adapter with a XPDM driver and another with a WDDM driver, then Windows Vista chooses the POST device, which is the one with VGA resources. This is commonly referred to as the "VGA adapter."

Windows Display Driver Model (WDDM)

Wikipedia Article on WDDM