Error: "The system could not log you on. Ensure that you entered your details correctly and try again" When Logging on to Web Interface

Error: "The system could not log you on. Ensure that you entered your details correctly and try again" When Logging on to Web Interface

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Article ID: CTX123418

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Updated On:

Description

When logging on to a Web Interface, the following error message appears:

“The system could not log you on. Ensure that you entered your details correctly and try again. If you are still unable to log on, contact your system administrator as your credentials may be invalid or there may be a problem with the authentication system.”

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Following are the event log errors for every failed logon on the Web Interface/Citrix Online Plug-in Web server:

Event Type: Error
Event Source: Citrix Web Interface
Event Category: None
Event ID: 31003
User: N/A
Computer: Servername
Description: Site path: c:\inetpub\wwwroot\Citrix\DesktopWeb.
All the Citrix XML Services configured for the farm XYZ failed to respond to this XML Service transaction.  [Unique Log ID: cc5a8976].

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This error might be followed by a second Event ID:

Event Type: Error
Event Source: Citrix Web Interface
Event Category: None
Event ID: 30110
User: N/A
Computer: Servername
Description: Site path: c:\inetpub\wwwroot\Citrix\DesktopWeb.
An error of type "IMA" with an Error ID of "0x80000001" was reported from the Citrix XML Service at address http://servername:80/scripts/wpnbr.dll [com.citrix.xml.NFuseProtocol.RequestValidateCredentials]. Depending on the server running the XML Service, more information may be available in the server’s event log.  This Citrix XML Service transaction failed, but the XML Service has not been removed from the list of active services. [Log ID: 8fcde615]…

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If you are experiencing similar issues with XenDesktop, you must complete the following as a workaround:

  1. Change the XML port on your DDC to be different from 8080 as this is the port that XenDesktop uses for WCF communication.
    You can change the port with the following command lines:

    ctxxmlss /u
    ctxxmlss /r8081
  2. Restart the XML service and ensure you can telnet the DDC on port 8081 from the Web Interface.

  3. Change your Web Interface server configuration to reflect this change.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Solution 1

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

Complete the following steps to resolve this issue on all XML broker servers:
  1. Add the necessary users to the policy. Access this computer from the network.

    Note: Adding the Remote Desktop Users group is easy.
  1. Configure the registry, DWORD value (UseNetworkLogon=1) under HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\IMA
The registry value introduces an option to enable access to published resources by enabling either the Access computer from the network or the Allow logon locally policies.

Consider the following to specify which of the two policies is required for users to access the published resources:

  • If the registry value UseNetworkLogon is present and the value is 1, access to this computer from the network must be enabled for users to start published applications. All other values are interpreted as zero, and Log On Locally must be enabled to start published applications.

  • If the registry value UseNetworkLogon is absent, by default, Log On Locally must be enabled.

The registry value is static and, if modified, you must restart the IMA Service for the change to take effect.

Solution 2

Using the Active Directory Users and Computer console, open the user account properties and click the Log On To on the Account tab. Add the server with Citrix XML service to the list.
 
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Problem Cause

Cause 1

The Access computer from the network policy is disabled. During the Logon to Web Interface site, Citrix checks Microsoft’s Access this computer from the network policy to ensure that the users have the necessary permission to access the server.

Cause 2

The user account has restrictions as to which workstations a user can log on to. While logging on to the Web Interface site, Citrix XML service tries to authorize the user in Active Directory using Kerberos.

Check the user account properties to ensure that the server with Citrix XML service is added to the list of workstation, which the user can log on to.

Issue/Introduction

This article provides resolutions to the error that appears when logging on to Web Interface.

Additional Information

CTX114769 - Web Interface Error: An error has occurred while trying to enumerate your applications.