The Explorer Starts When Starting a Published Application

The Explorer Starts When Starting a Published Application

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Article ID: CTX120831

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Updated On:

Description

The Explorer desktop starts when the Domain users try to connect to an Independent Computing Architecture (ICA) published application, fixed or seamless, or a Remote Desktop Protocol (RDP) session configured for an Initial Program.

The issue does not occur with Domain Administrators.

Resolution

As a workaround, complete any of the following methods:

Method 1

Fix the issue by completing the following procedure:
  1. Run a script similar to the following and ensure to edit the LDAP line to match the environment and the user:
    Const ADS_PROPERTY_CLEAR = 1 
    Set objUser = GetObject _
    ("LDAP://cn=MyUser,ou=MyOU,dc=MyDomain,dc=com") 
    objUser.PutEx ADS_PROPERTY_CLEAR, "userParameters", 0
    objUser.SetInfo

  2. Set a GPO to alter the Terminal Server home or the profile directory.

    Note: If initially used GPOs to modify the Terminal Server Home Profile directly, then the account does not become unusable.

      Method 2

      Use the Windows 2003 Active Directory Users and Computers Microsoft Management Console (MMC), in the Windows 2008 domain to modify the accounts.
      Microsoft recommends to enable the GPO setting Allow remote start of unlisted programs to resolve the issue.
      Refer to the Instead of the specified startup program, the whole desktop is started on a remote desktop connection when you change the "Terminal Services Profile" setting for the user account web page of Microsoft Support for information about applying the Microsoft Hotfix to resolve the issue.

      To apply the hotfix, the computer must run one of the following operating systems:

      • Windows Server 2008
      • Windows Server 2008 Service Pack 2
      • Windows Server 2008 R2

        Problem Cause

        Editing Terminal Server Home or Profile directly in Windows 2008 Active Directory Users and Computers Management Console makes the Active Directory (AD) account unusable. When the account becomes unusable, this issue cannot be resolved even by migrating to the Group Policy Object (GPO).

        Issue/Introduction

        The Explorer desktop starts when the Domain users try to connect to an Independent Computing Architecture (ICA) published application, fixed or seamless, or a Remote Desktop Protocol (RDP) session configured for an Initial Program.

        Additional Information

        CTX112134 – ICA Seamless Host Agent Dialog Box Displayed when Connecting to a Seamless Application