Microsoft Management Console Based Administrative Consoles Takes an Extended Time to Start
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Article ID: CTX120115
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Updated On:
Description
Citrix Microsoft Management Console (MMC) based administrative consoles such as Access Management Console, Citrix Studio take an extended time to start when running on Windows 2008 R2 and earlier or Windows 7 and earlier. After the initial launch, the consoles operate as expected.
Environment
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Resolution
To resolve this issue, you can either provide the computer with internet access so it can verify the Authenticode signature, or disable the Authenticode signature checking feature for Microsoft Management Console, as explained in the following section:
XenApp 6.0
In XenApp 6, a dialog is shown if Authenticode signature checking has not been disabled on the system, as displayed in the following screen shot:

XenApp 5.0, XenDesktop 5.0 and earlier Citrix software releases
Note: This article assumes you have Access Management Console or Delivery Services Console installed on a system. These releases ship with products such as XenApp, XenDesktop, Password Manager, and Access Gateway Advanced Edition.
Important! To implement the following resolution, you must have one of the following Microsoft .NET Framework versions installed:
- Microsoft .NET Framework 2.0 with KB936707 Hotfix
- Microsoft .NET Framework 2.0, Service Pack 1 or later
- Microsoft.NET Framework 3.0 or later
- Microsoft.NET Framework 3.5 or later
For 32-bit Windows Installations:
-
Create a file in c:\windows\system32\ called mmc.exe.config.
-
Place the following text inside the file and save it:
<?xml version="1.0" encoding="utf-8"?>
<configuration>
<runtime>
<generatePublisherEvidence enabled="false" />
</runtime>
</configuration>
-
Restart the Access Management Console/Delivery Services Console. This must be much faster because the system does not attempt to verify the Authenticode signature.
For 64-bit Windows Installations:
- Create a file in C:\Windows\SysWOW64 called mmc.exe.config.
- Place the following text inside the file and save it:
<?xml version="1.0" encoding="utf-8"?>
<configuration>
<runtime>
<generatePublisherEvidence enabled="false" />
</runtime>
</configuration> - Restart the Access Management Console/Delivery Services Console. This should be much faster because the system does not attempt to verify the Authenticode signature.
For Desktop Studio on XenDesktop 5.0:
The following might also be required:
-
Locate the Desktop Studio folder on the system:
C:\Program Files\Citrix\Desktop Studio\ (32-bit machines and 64-bit machines with 64-bit Desktop Studio)
OR
C:\Program Files (x86)\Desktop Studio\ (64-bit machines with 32-bit Desktop Studio)
Note: Verify that the LaunchConsole.exe file is present in this folder
-
Create a file in the \Desktop Studio\ folder named LaunchConsole.exe.config.
-
Place the following text inside the file and save it:
<?xml version="1.0" encoding="utf-8"?>
<configuration>
<runtime>
<generatePublisherEvidence enabled="false" />
</runtime>
</configuration>
-
Restart the Desktop Studio Console. This must be much faster because the system does not attempt to verify the Authenticode signature.
Problem Cause
Citrix MMC based administrative consoles feature components that are written using the Microsoft .NET Framework. Citrix signs these .NET based components with an Authenticode signature as an added security mechanism.
In situations where a Citrix MMC based administrative console is run from a computer without internet access, Windows is unable to verify the Authenticode signature, and as a result this causes a delay during the startup of the console.
Issue/Introduction
How to resolve the issue of the Access Management Console/Delivery Services Console taking an extended period of time to start.
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