User Sessions Experience 60 to 90 Seconds Delay - Orphaned Printers

User Sessions Experience 60 to 90 Seconds Delay - Orphaned Printers

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Article ID: CTX119919

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Updated On:

Description

Users experience 60 to 90 seconds delay when running published applications. This might be reported as a session freeze, hang, or delay. During the delays, sessions and the applications running inside the affected sessions are unresponsive to keyboard and mouse input.

Products Affected

  • Citrix Presentation Server/XenApp 4.0, 4.5, and 5.0 (share similar general printing architecture).

  • ICA Client (XenApp Plug-in) 9.x and later (because 9.x is required to use the affected version of the UPD).

Resolution

Complete the following steps t​o fix the issue:

  1. Examine the user's printers inside the affected ICA session.

    1. Are they using the Citrix Universal Print Driver (UPD)? If no, then it is not the same issue.
      User-added image
    2. Examine the printers in the session to determine if all the user's printers in the session are present on their client device. If yes, then there are no orphaned printers, and this is not the same issue.
      If there are orphans, delete them from the session and verify the issue is resolved - orphaned printers are an issue in and of themselves and correcting them resolves the issue.
  1. Collect a Common Diagnostics Facility (CDF) trace on MF_Service_CpSvc to determine why printers are not being deleted at log off and during the cleanup process that the Citrix Print Manager Service runs every five minutes.
    1. One issue that could prevent the Citrix Print Manager Service from removing an orphaned printer is if the account the service runs under does not have permissions to the printer. Examine the Access Control List of the orphaned printer to verify that the account has access to the printer.
    2. You can use CDF Control or the Access Suite or Access Management Consoles to collect a CDF trace.
      CTX104578 - How to use Citrix Diagnostic Facility and the Access Suite Console to Trace Issues

  1. Collect a process dump of the wfica32.exe and spoolsv.exe processes during the hang if it is determined that there are orphaned printers in the session. See CTX466627 - How to Use the Userdump.exe Tool to Create a Dump File.
Important! When the orphaned printers are identified, focus on addressing the issue. Removing and preventing orphaned printers prevents this issue from occurring. Some of the preceding steps might be requested by your source of technical support and be beyond the scope of your duties.
Contact the appropriate party as your organization has arranged.  

Problem Cause

There are a variety of networking, hardware, and performance, related factors which can cause sluggishness, delays, or freezes. In this instance the focus is on orphaned printers as the cause - orphaned printers and the specific conditions causing the problem are further defined.

5 Simultaneous Conditions are Required for this problem to Occur

  1. There must be an orphaned printer present in the user's session - an orphaned printer is a printer that is left behind from a user that previously logged on to a session with the same session ID as the current user and not deleted. Orphaned printers are a problem in and of themselves. By design, client printers must be deleted when users log off their sessions. Additionally, if a problem occurs and the printer cannot be deleted at log off, the Citrix Print Manager service has a clean-up routine which deletes any client printers which do not have sessions associated with them. Orphaned printers are not a common occurrence in a healthy environment.

  2. The orphaned printer must be using the Citrix Universal Print Driver (UPD) for problem occurrence. If the printer is not using the UPD, the query to get device capabilities for the printer is answered on the server without sending a query to the client.

  3. The client machine must not have the orphaned printer installed - the delay occurs because the client does not have the information for the printer (because it was not installed) - it attempts to map the network printer that the orphan represents.

  4. The orphaned network printer must be accessible from the client. If the printer is not accessible, the client fails faster, meaning the session does not have a lengthy delay or hang.

  5. A software component installed on the server with the orphaned printer must request the device capabilities of an orphaned printer. Requesting device capabilities is a common operation performed when Windows applications want to determine the capabilities of a printer device driver, for example, EdgeSight using Windows Management Instrumentation (WMI) to query for printer information.

    Issue/Introduction

    This article contains procedure to troubleshoot 60 to 90 Second delay experienced in User Sessions - Orphaned Printers.

    Additional Information

    CTX122425 - Applications Appear to be Unresponsive During Session Launch because of Inaccessible Print Servers or Orphaned Printers
    CTX101705 - How to Troubleshoot Slow Logons