vDisk Inactive State with Broadcom Network Cards

vDisk Inactive State with Broadcom Network Cards

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Article ID: CTX119000

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Updated On:

Description

After installing Citrix Provisioning Services Server Target Device Software on a client computer that has a Broadcom Network Interface Card and restarting the target device, the Provisioning Services (PVS) status in the system tray displays Inactive.

After initially installing the Target Device software (and before restarting), the vDisk appears in an active state and can be seen in Disk Management.

After restarting the target device (PXE Boot) with the Target Device set to boot from hard disk, when the system loads – the PVS Server system tray status appears inactive and you cannot access the vDisk.

Examining the status of the Citrix Network Stack Interface Driver in Device Manager on the Target Device displays the following status:

User-added image

The following event might appear in the Event Viewer Application Log:

Source: StreamProcess
Event ID: 11
Description: DbAccess error: <Record was not found> <-31754> (in DeviceStatusDelete() called from .\SSProtocolLogin.cpp:923)

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

The following are the two resolutions for this issue:

Resolution A

Use the Broadcom NetXtreme II Driver instead of the VBD Driver if possible for affected NICs that exhibit this issue.

Resolution B

Set both parts of the VBD Driver to load in the first set of drivers that Windows loads by completing the following steps:
  1. Uninstall the PVS Server Target Device software from the Target Device and restart the computer.

    (Optional) – Update the VBD NIC drivers to the latest available version or a revision above the minimum recommendation from Citrix.

  2. Reinstall the PVS Server Target Device Software and restart when prompted.

  3. PXE Boot the Target Device from the PVS Server – set the Target Device to start from local hard drive so that an image can be transferred to the vDisk.

Use regedit32.exe to make the following registry changes for your relevant NIC driver version:

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

NIC Driver earlier than 3.4.10

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\b06bdrv
Add or modify String “Group” Value: NDIS
Add or modify DWORD “Start” Value: 0
Add or modify DWORD “Tag” Value: 2
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ndisuio
Add or modify DWORD “Start” Value: 0
Add or modify DWORD “Tag” Value: 2

Note: After making these changes, restart the computer. After restarting the Target Device, the PVS Server Status Tray icon should show that the vDisk is active and you can interact with the vDisk.

NIC Driver 3.4.10 and later

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wdf01000
Add or modify String “Group” Value: NDIS
Add or modify DWORD “Start” Value: 0
Add or modify DWORD “Tag” Value: 1

Note: After making these changes, restart the computer. After restarting the Target Device, the PVS Server Status Tray icon should show that the vDisk is active and you can interact with the vDisk.

HP NC7781 Gigabit Server Adapter

For the HP NC7781 Gigabit Server Adapter, in addition to the preceding changes you need to perform the following modification:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\q57w2k:
Change the default values of these keys:
Group: base -> NDIS
Tag: 0x12 -> 2 

Problem Cause

When the PVS Server Target Device software starts, the Network Interface Card Driver must be in the first set of drivers loaded so that it can provide access to the PVS Server vDisk over the network.

Unlike most of other Network Interface Card drivers, the Broadcom NetXteme II VBD NIC has two drivers. The PVS Server Target Device can only bind to the first set of drivers that are loaded during startup. The second Broadcom Driver then gets loaded in the second set of drivers, which PVS Server has not hooked into. This then creates the failure condition with the symptoms as described above.

The following hardware can potentially exhibit this behavior:
  • IBM HS21 Blade Servers with the Broadcom NetXtreme II VBD Driver

  • HP ProLiant Blade Servers with the following NIC drivers:

  • HP NC-Series Multifunction Driver

  • HP NC-Series Broadcom Driver

  • HP NC7781 Gigabit Server Adapter

Recommendation: Depending on the type of Network Interface Card, use the minimum driver versions as follows:
  • HP NC-Series Multifunction Driver for Windows Server 2003. Version 3.0.7.0 (21 Mar 07).

  • HP NC-Series Broadcom Driver for Windows Server 2003. Version 10.24.0.0 (21 Mar 07).

Issue/Introduction

vDisk Inactive State with Broadcom Network Cards.