Error: "STOP: 0x0000007B ... " After Updating the Virtual Machine Tools on Provisioning Services

Error: "STOP: 0x0000007B ... " After Updating the Virtual Machine Tools on Provisioning Services

book

Article ID: CTX118263

calendar_today

Updated On:

Description

After switching vDisk to Private Mode and upgrading the hosting infrastructure’s Virtual Machine tools (VM tools), Virtual Machine stops and displays a blue screen with the following stop error:
STOP: 0x0000007B

User-added image

Note: This behavior does not occur with Microsoft’s Hyper-V Integration Services.

Resolution

Complete the following procedure to update the VM tools on the Provisioning Services (PVS) Server target device:
  1. Configure the Master Target Device Virtual Machine to start up with the hard disk first (if the Master Target Device's hard drive no longer exists, you can perform a reverse image. Refer to Image Back to Master Target Devices Hard Drive.

  2. Uninstall the PVS Server Client software using Add or Remove Programs.

  3. Use the hosting infrastructure’s documentation to update the VM tools.

  4. Restart the Virtual Machine and install the PVS target device software.

  5. Configure the Virtual Machine to start up using the network through a Preboot Execution Environment (PXE).

  6. When the client starts successfully, start Imaging Wizard to build a new image.

  7. Assign the new image to the appropriate Target Devices.


Problem Cause

Installing XenServer Tools or VMware Tools on an existing installation of the Provisioning Services Server Client software replaces the modified Network Interface Card (NIC) driver and removes the bnnf.sys file from its configuration. This replacement destroys the Citrix Network Stack and prevents the Virtual Machine from starting successfully.

Issue/Introduction

This article provides a resolution to the error "STOP: 0x0000007B" that occurs after updating the Virtual Machine Tools on Provisioning Services.

Additional Information

CTX117395 - How to Make the Provisioning Server Client Coexist with Third-party Network Drivers

CTX117133 - If You Deploy a Virtual Disk to a Target Device Different from the Master Target, the Computer Crashes

Microsoft Knowledge Base article Advanced troubleshooting for "Stop error code 0x0000007B (INACCESSIBLE_BOOT_DEVICE)" errors in Windows XP