The XTE Service is Not Starting After Installing Secure Gateway

The XTE Service is Not Starting After Installing Secure Gateway

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Article ID: CTX118021

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Updated On:

Description

The Citrix XTE Service will not start after installing the Secure Gateway in a XenApp or Citrix Access Essentials environment.

The event viewer shows:

Event ID 3299: “Syntax error on line 3 of <full path to httpd.conf>.”

Attempting to run the XTE executable manually results in an error message:

“Syntax error on line 3 of <full path to httpd.conf>: ServerRoot must be a valid directory.”

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

To correct the registry path so that the XTE service starts automatically, complete the following procedure:

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

  1. Find the correct path using “ImagePath” key in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CitrixXTEServer. It contains a value as:
    "C:\Program Files\Citrix\XTE\bin\XTE.exe" -k runservice -n "CitrixXTEServer" -f "conf/httpd.conf"

  1. Copy that value to the registry key “ServerRootPath” in HKEY_LOCAL_MACHINE\Software\Citrix\XTEConfig, overwriting the path to Secure Gateway.
     on x64 bit Operating System HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\XTEConfig

  2. Modify the string value in “ServerRootPath” in the following manner:

    1. Remove the leading quote

    2. Remove everything after and including \bin\XTE.exe

    The resulting string will be similar to C:\Program Files\Citrix\XTE.

  3. Restart the computer.

The path must not contain quotes or trailing backslash ( \ ) character.


Problem Cause

The registry key “ServerRootPath” in HKEY_LOCAL_MACHINE\Software\Citrix\XTEConfig, which needs to contain the path to XTE, has been overwritten as a result of the Secure Gateway installation.

The registry must contain C:\Program Files\Citrix\XTE as path. Instead it contains C:\Program Files\Citrix\Secure Gateway\ as path.

Issue/Introduction

Registry change to allow XTE to function even after Secure Gateway is installed in a XenApp or Access Essentials environment.