Printer Driver Replication Process Fails on XenApp Servers

Printer Driver Replication Process Fails on XenApp Servers

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Article ID: CTX115933

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Updated On:

Description

When a native or third party printer drivers are replicated, the process fails with the following:

  • MetaFrame Event ID 1111is being logged in the Application event log of the target server:
    “An error occurred at the following source server while trying to replicate a driver: Source Server Name: ( for example CTX01) Driver Name: (for example HP LaserJet 4200 PCL 6)”

  • Corresponding MetaFrame Event ID 1102 is being logged in the Application event log of the source server:
    “Printer driver replication failed. Printer driver: (for example HP LaserJet 4200 PCL 6) Destination server: (for example CTX02)"

Resolution

To ensure successful printer driver replication, verify the following points before attempting to initiate the process:

  • The IMA service must be running on both the source and target servers.

  • The Network Service account must have the preceding permissions on the temporary folder on the target server. In locked down environments (for security reasons), the default permissions of the Network Service account are being modified or restricted. As a workaround, the IMA service could run in the security context of the Local System account. This account was used with IMA service in the previous versions of MetaFrame.
    Note: This article does not apply to XenApp 6.5 on Windows 2008 R2. For information on how to replicate print drivers in this environment, refer to CTX126125 - How to Replicate Print Drivers with PowerShell in XenApp 6.x.


Problem Cause

The printer driver replication process is failed because the Network Service account does not have the required security permission on the temporary folder (C:\Program Files\Citrix\System32\Citrix\IMA\Temp) in the target server.
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By default, the Independent Management Architecture (IMA) service runs in the security context of the Network Service account in the Citrix Presentation Server 4.5, XenApp 5.0 and XenApp 6.0.
Citrix Management Console communicates with the IMA service to copy the selected print driver files from the source server to the temporary folder on the target server. IMA monitors the file copy and also calls the PrintUI.dll on the target server to install the printer driver.

Issue/Introduction

This article provides a resolution for the printer driver issue that failed to replicate process on XenApp servers.

Additional Information

CTX774641 - Printer Driver Replication Fails for Certain Printer Drivers
CTX103308 - FAQ: Using DSCHECK to Purge Print Driver Replications