The IMA Service Fails to Start After Restarting the XenApp Server

The IMA Service Fails to Start After Restarting the XenApp Server

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Article ID: CTX112685

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Updated On:

Description

The IMA Service fails to start after restarting a XenApp server.
The following error is displayed in the System Event Log.
"Failed to load plugin C:\Program Files\Citrix\System32\Citrix\IMA\Subsystems\RADESessionSs.dll with error IMA_RESULT_FAILURE"
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Resolution

To resolve the preceding issue, complete the following procedure:

  1. Run the following command from the affected server to re-create the RadeOffline.mdb file, as shown in the following screen shot:
    Dsmaint recreaterade
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  2. Restart the IMA Service after the RadeOffline.mdb file is re-created.


Problem Cause

If the RADESessionSs.dll plugin is present in the IMA Subsystems directory, the RadeOffline.mdb file is either missing or corrupt.

Issue/Introduction

This article provides resolution to start IMA service after restarting the XenApp server.

Additional Information

CTX105292 – Troubleshooting IMA Service Faliure To Start