Changes to Client Drive Files are Not Immediately Updated

Changes to Client Drive Files are Not Immediately Updated

book

Article ID: CTX103825

calendar_today

Updated On:

Description

When changes are made to the file content on a local device, the changes are not immediately reflected through the GUI.

Steps to reproduce the issue:

  1. Launch ICA session from a Client device.

  2. Open the mapped client drive in ICA session. For example, C$ on ‘Client’ (V:)).

  3. Open an existing text file on the mapped client drive using Notepad.exe in a local device, change the content, and save (for example, change and save “test.txt” on the local C drive).

  4. Open the text file saved in Step 3 in an ICA session.
    The change of the text file is not reflected in the ICA session.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

Update the registry key on VDA to adjust the caching time. The time out value for the caching is in seconds. The value can be set to 0 seconds to disable the caching function of CDM.sys. Setting the value to 0 might impact system performance.
 

File caching time out value (default: 60sec)

Key: HKLM\SOFTWARE\Policies\Citrix\CDMSettings
Name: CacheTimeout
Type: DWORD
Data: 0x3c
note: These registry changes does NOT require reboot to take effect.
 

On Citrix Virtual Apps and Desktops 7 2003 Server VDA or prior:
( eg: Server VDA 7.15 LTSR, 1912 LTSR, 2003 CR )

Key: HKLM\System\CurrentControlSet\Services\picadm\Parameters
Name: CacheTimeout
Type: DWORD
Data: 0x3c
note: These registry changes require reboot to take effect.

 

Directory caching time out value (default: 30sec)

Key: HKLM\SOFTWARE\Policies\Citrix\CDMSettings
Name: DirCacheTimeout
Type: DWORD
Data: 0x1e
note: These registry changes does NOT require reboot to take effect.
 

On Citrix Virtual Apps and Desktops 7 2003 Server VDA or prior:
( eg: Server VDA 7.15 LTSR, 1912 LTSR, 2003 CR )

Key: HKLM\System\CurrentControlSet\Services\picadm\Parameters
Name: DirCacheTimeout
Type: DWORD
Data: 0x1e
note: These registry changes require reboot to take effect.



For cache configuration of removable mass storage devices, a new key “RemoveableCacheTimeout” is introduced. 

Removable mass storage device caching time out value ( default: 10 sec)

Key: HKLM\SOFTWARE\Policies\Citrix\CDMSettings
Name: RemoveableCacheTimeout
Type: DWORD
Data: 0xa
note: These registry changes does NOT require reboot to take effect.
 

On Citrix Virtual Apps and Desktops 7 2003 Server VDA or prior:
( eg: Server VDA 7.15 LTSR, 1912 LTSR, 2003 CR )

Key: HKLM\System\CurrentControlSet\Services\picadm\Parameters
Name: RemoveableCacheTimeout
Type: DWORD
Data: 0xa
note: These registry changes require reboot to take effect.


Problem Cause

The caching mechanism of XenApp Server drive mapping, CDM.sys, is set to 60 seconds.  Therefore, there is a time delay for the file change to occur in ICA session.

Issue/Introduction

When changes are made to the file content on a local device, the changes are not immediately reflected through the GUI.