IMA Service Failed to Start with Error 2147483649 and Failed to Load Plug-ins

IMA Service Failed to Start with Error 2147483649 and Failed to Load Plug-ins

book

Article ID: CTX103253

calendar_today

Updated On:

Description

The IMA Service fails to start and displays the error “The IMA service returned a specific error 2147483649.”. The Event viewer displays the following event IDs:

Event ID: 3601, “Failed to load plug-ins with error 80000001h.”

Event ID: 3609, “Failed to load initial plug-ins with error 80000001h.”

Event ID: 7024, “The Independent Management Architecture service terminated with service-specific error 2147483649.”

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

To resolve the issue, complete the following steps:

  1. Browse to the following locations:
  • x32-bit:
    HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\IMA

    Value: Directory (REG_SZ)
    C:\ProgramFiles\Citrix\System32\Citrix\IMA\SubSystems

    Value: PluginDirectory (REG_SZ)
    C:\Program Files\Citrix\System32\Citrix\IMA\SubSystems

  • x64-bit:
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\IMA

    Value: Directory (REG_SZ)
    C:\ProgramFiles (x86)\Citrix\System32\Citrix\IMA\SubSystems

    Value: PlugithnDirectory (REG_SZ)
    C:\ProgramFiles (x86)\Citrix\System32\Citrix\IMA\SubSystems

  1. Verify that the location specified matches the exact location where all the plug-ins are on the disk.


Problem Cause

One of the causes could be upgrading to a new service pack or after an attempt to restore a backup. The plug-in that is not loading shows as the value for CurrentlyLoadingPlugin under:

32-bit: HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\IMA\RUNTIME

64-bit: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\IMA\RUNTIME

Issue/Introduction

This article provides a resolution for the XenApp Error: IMA Service Failed to Start with Error 2147483649 and Failed to Load Plug-ins.

Additional Information