Error: Windows could not start the Independent Management Architecture on Local Computer...refer to service-specific error code -2147483647

Error: Windows could not start the Independent Management Architecture on Local Computer...refer to service-specific error code -2147483647

book

Article ID: CTX101917

calendar_today

Updated On:

Description

When a domain or local user is configured, the IMA Service fails to start and the following error message appears:
“Windows could not start the Independent Management Architecture on Local Computer... Refer to service-specific error code –2147483647.”

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

To solve the issue, edit the following registry:

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

  1. Add the local or domain user to the local Administrators group.

  2. When selecting the user account in the IMA Service Logon dialog box, ensure The account has been granted the Logon as a Service dialogue box appears. If it does not appear, manually grant the right to the user.

  3. Open Regedt32.exe and grant Full Control rights to the local Administrators group on the following registry key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\IMA\Data


    Problem Cause

    The domain or local user must have full control for several files and registry entries. Must also have Log On As A Service right on the local machine.

    Issue/Introduction

    This article provides resolution to Error: "Windows could not start the Independent Management Architecture on Local Computer .. and refer to service-specific error code -2147483647".

    Additional Information

    CTX032712 - Error: IMA Service Error Message - 2147483647 - IMA_RESULT_FAILURE

    CTX103048 - IMA Service Fails to Start when a Domain or Local User is Configured for Logon

    CTX103253 - Error: IMA service failed to start with error 2147483649 and failed to load plug-ins

    CTX104200 - Faliure to Start IMA Service in CTX_MF_IMA_StartIMAService

    CTX105292 - Troubleshooting IMA Service Faliure To Start

    CTX134504 - IMA Fails To Start On XenApp 6.5 with Specific Error Code - 2147483588

    CTX440269 - Error: "Setup Could not Start the IMA Service"

    CTX735338 - IMA Fails to Start with Error Code 2147483649