XenApp Error: An error occurred while attempting to start the IMA Service

XenApp Error: An error occurred while attempting to start the IMA Service

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Article ID: CTX101877

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Updated On:

Description

The error “An error occurred while attempting to start the IMA service” occurs with some or all of the following Event Viewer Event IDs:

  • 3609: Failed to load plug-in IMAPsSs.dll/ImaRuntimeSs.dll with error IMA_RESULT_ACCESS_DENIED.

  • 3612: The Citrix MetaFrame server failed to connect to the data store. IMA_RESULT_ACCESS_DENIED. Invalid database user name or password.

  • 3601: Failed to load initial plug-ins with error IMA_RESULT_ACCESS_DENIED.

  • 7024: The Independent Management Architecture service terminated with server-specific error 2147483670.

The following error message appears when starting the IMA Service:
"Windows could not start the Independent Management Architecture on Local Computer…contact the service vendor, and refer to server-specific error code -2147483626."
See CTX103345 – Errors when Using dsmaint to Connect to the Data Store Database for more information.

Resolution

Refer to CTX133983 – IMA Helper Tool to resolve the issue.

When running CHFARM, ensure that the screen after creating the Open Database Connection (ODBC), ODBC Driver Access, prompts for a username, password, and to re-enter password containing a user name with a syntax of DomainName\UserName.

When running DSMAINT CONFIG, ensure that the source and destination user name has syntax of DomainName\UserName.

Alternatively, use another account that has DB permissions for create a new DSN file as follows

 

  1. On the XenApp server Open Microsoft ODBC manager .
  2. Open 'File DSN' Tab ('look in': %system%\Program Files\Citrix\Independent Management Architecture\)
  3. Click Add and select the Database and type the Name as 'mf22'. Configure the connection pointing to the existing database using the Credentials of the new user.
  4. Stop the IMA service
  5. On the command run the below command:
    • Reconfigure to point to new DSN file
dsmaint config /user:yourdomain\youraccount /pwd:yourpassword /dsn:"C:\Program Files (x86)\Citrix\Independent Management Architecture\mf22.dsn"
 
  • Recreate Local host cache
    dsmaint recreatelhc

     
  • Recreate RADE
    dsmaint recreaterade

Problem Cause

Running CHFARM using SQL database configured for Windows authentication causes the error. Running the same commands, in the same environment, using SQL account is successful.

Note: The user account that is used to access the data store on Microsoft SQL Server has public and db_owner roles on the server and database. System administrator account credentials are not needed for data store access; do not use a system administrator account because this poses an inherent security risk.

If the Microsoft SQL Server is configured for mixed mode security (you can use either Microsoft SQL Server authentication or Windows NT authentication), you might want to create a Microsoft SQL Server user account for the single purpose of accessing the data store. Because this Microsoft SQL Server user account would access only the data store, there is no risk of compromising a Windows domain if the user’s password is compromised.

For tighter security, the user account’s permission can be changed to db_reader and db_writer after the initial installation of the database with db_owner permission.

Important! Changing the user account’s permission from db_owner might cause problems installing future service packs or feature releases for Presentation Server. Ensure to change the account permission back to db_owner before installing a service pack or feature release for Presentation Server.

Issue/Introduction

This article provides resolution to Error: An error occurred while attempting to start the IMA Service.

Additional Information

http://support.citrix.com/article/CTX108699