Symptoms or Error
The black Desktop Viewer toolbar does not show up in the XenApp or XenDesktop ICA session of the user.
Solution
To resolve this issue, complete the following steps:
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Log on to the machine hosting the Web Interface as an administrator user.
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Edit the WebInterface.conf file in both these locations.
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Open the C:\Inetpub\wwwroot\Citrix\XenApp\conf folder for Web Interface connections.
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Open the C:\Inetpub\wwwroot\Citrix\PNAgent\conf folder for PNAgent connections.
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Update the configuration file to remove the '#' and set ShowDesktopViewer=On.
Problem Cause
This issue is caused by disabling ShowDesktopViewer parameter in the WebInterface.conf file on the Web Interface server.
Additional Resources
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CTX131863 - Citrix Desktop Viewer Toolbar not Available in XenDesktop when using Receiver StoreFront
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Citrix Documentation - Keyboard input in Desktop Viewer sessions