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CTX132117

Error 1603 While Installing or Removing XenApp or XenDesktop

Applicable Products

  • XenDesktop
  • XenApp

Symptoms or Error

When trying to install or remove any XenApp Software (including hotfixes and rollup packs), a 1603 Windows error message is displayed. The following are the possible error messages that are displayed when trying to install or remove any XenApp Software:

Error 1603: A fatal error occurred during installation

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Installation ended prematurely because of an error
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Fatal Error during installation
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You might also notice the following when trying to remove any hotfix or rollup pack using cpatch command:

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Note: Find more possible causes and solutions in the Additional Resources section.


Solution

Complete the following steps to resolve this issue:

  1. Reboot twice to ensure there are no more pending reboot requests.
    Try your installation again. If the problem persists continue to Step 2.

  2. Check the Windows Installer Service.

    Try your installation again. If the problem persists continue to Step 3.

    1. Click Start > Run, and type Services.msc and press Enter.
    2. Scroll down and find the Windows Installer. Double-click Windows Installer in the Services list.
    3. On the General tab, ensure the service is started under Service status.
    4. If the service is not already running, under Service status, click Start, and then click OK.
  3. Unregister and then re-register the Windows Installer Service.

    Try your installation again. If the problem persists continue to Step 4.

    1. Click Start > Run, and type msiexec /unreg in the Open text box; click OK.
    2. Click Start > Run, and type msiexec /regserver in the Open text box; click OK.
  4. Search and remove any InProgress installations.
To search for the InProgress reg subkey on a system enter a command that uses the following syntax:

reg /query [\\ComputerName]\HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\InProgress
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       5. Ensure the Device Install Service is not disabled.

 

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.      

To clean any pending installations check the following registry key and clean any entries in the key that you find:  

  1. Click Start, and then click Run.

  1. In the Open box, type regedit, and then click OK.

  1. Locate the following reg key:
    HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress

  1. Select the key, and then press Delete.

  1. Click Yes to confirm the delete operation.

  1. On the Registry menu, click Exit to quit the Registry Editor.

Try your installation again. If the problem persists contact Citrix Technical Support for further assistance.


Problem Cause

When an installation does not complete or roll back successfully, some remnants of the installation might remain in the system. Windows Installer considers the incomplete installation to be active and does not install new products or re-install existing products until the installation is resolved. Because Windows Installer runs only one installation at a time, only one installation is active at any given time and there is only one instance of the indicator objects on any system.

The following object indicates an active, incomplete installation on the system. When an installation completes successfully, Windows Installer automatically deletes this object from the system. The InProgress registry subkey: HKLM\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress

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Additional Resources


Disclaimer

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

View Common Solutions