Citrix

Updating Inventory Fails with Error: The personal vDisk failed to update

  • CTX139296
  • Created onMar 26, 2014
  • Updated onApr 08, 2014
Article Topic Installation/Upgrade

Symptoms or Error

Updating Inventory fails with the following error:

“The personal vDisk failed to update.”

User-added image

Solution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

  1. Increase the minimum size of app container to 4096 MB (4 GB, by default it is 2 GB).

HKLM\Software\Citrix\personal vDisk\Config\MinimumVHDSizeMB

Note: Remember to enter values in decimal if using regedit..
  1. Restart the machine and then update the inventory again with command prompt:

C:\Program Files\Citrix\personal vDisk\bin\CtxPvD.exe –s inventory

User-added image

Status

After updating the inventory, the master vm will shut down automatically.

Problem Cause

In the personal vDisk logs, the following entry can be noticed:

Failed to generate the sentinel file corresponding to the host file \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy1\Windows\winsxs\amd64_netfx-aspnet_webadmin_wizard_b03f5f7f11d50a3a_6.1.7600.16385_none_f3ab6fef34443b5c\wizardInit.ascx,Error:112.

Disclaimer

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Applicable Products

Automatic translation

Important: This article was translated by an automatic translation system (also referred to as Machine Translation, or MT) and has not been translated or reviewed by people. Citrix offers a machine translated version of this article to allow for greater access to the support content. However, automatic translation is not always perfect and may contain errors of vocabulary, syntax or grammar. Citrix is not responsible for inconsistencies, errors or damage incurred as a result of the use of MT articles from our customers.Thank you.
Click here to see the English version of this article.
Languages
Was this helpful?
Thank you for your feedback

Share your comments or find out more about this topic

Citrix Forums