Citrix

Vulnerability in XenDesktop 7.0 Upgrade Could Result in Policy Bypass

  • CTX138627
  • Created onOct 22, 2013
  • Updated onSep 08, 2014
Security Bulletin Severity Medium

Description of Problem

A vulnerability has been identified in Citrix XenDesktop 7.0 that could prevent policy rules from being correctly applied following an upgrade from earlier versions of Citrix XenDesktop.

This vulnerability affects deployments of Citrix XenDesktop that have been upgraded from version 5.6 or earlier to version 7.0. Customers upgrading from Citrix XenDesktop version 5.6 or earlier directly to Citrix XenDesktop version 7.1 are not affected by this vulnerability.

This vulnerability has been assigned the following CVE number:

    • CVE-2013-6077: Failure to correctly apply policy rule permissions following upgrade of Citrix XenDesktop from version 5.x to version 7.0.

What Customers Should Do

Customers that have upgraded from Citrix XenDesktop version 5.6 or earlier to Citrix XenDesktop version 7.0 are advised to verify that that their policy rules have the correct permissions. Further information on how to verify and reset policy rule permissions can be found in the Citrix Knowledge Center and the location below:

CTX139335 – How to Use PowerShell to Reset BrokerAccessPolicyRule Settings for XenDesktop

Customers currently planning upgrades from Citrix XenDesktop 5.6 or earlier may wish to consider upgrading to version 7.1 directly.

What Citrix Is Doing

Citrix is notifying customers and channel partners about this potential security issue. This article is also available from the Citrix Knowledge Center at http://support.citrix.com/.

Obtaining Support on This Issue

If you require technical assistance with this issue, please contact Citrix Technical Support. Contact details for Citrix Technical Support are available at http://www.citrix.com/site/ss/supportContacts.asp.

Reporting Security Vulnerabilities to Citrix

Citrix welcomes input regarding the security of its products and considers any and all potential vulnerabilities seriously. If you would like to report a security issue to Citrix, please compose an e-mail to secure@citrix.com stating the exact version of the product in which the vulnerability was found and the steps needed to reproduce the vulnerability.

Applicable Products

Was this helpful?
Thank you for your feedback

Share your comments or find out more about this topic

Citrix Forums